This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 246707 - netpbm pm.h : typoed def for non GNU C compilers.
netpbm pm.h : typoed def for non GNU C compilers.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: netpbm (Show other bugs)
5.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-04 04:50 EDT by Jose Plans
Modified: 2013-07-02 19:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:18:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
netpbm-non_gnu_c_pm_h.patch (335 bytes, patch)
2007-07-04 04:50 EDT, Jose Plans
no flags Details | Diff

  None (edit)
Description Jose Plans 2007-07-04 04:50:50 EDT
Description of problem:
Netpbm's pm.h header provides a macro/def that seems to be a typo and affects
non-GNU compilers.

[...] ./lib/pm.h [...]
#ifdef __GNUC__
#define PM_GNU_PRINTF_ATTR(a,b) __attribute__ ((format (printf, a, b)))
#else
#define PM_GNU_PRINTF_ATTR
#endif
[...] ./lib/pm.h [...]

void PM_GNU_PRINTF_ATTR(1,2)
pm_message (const char format[], ...);

When __GNUC__ is not defined, this will result in:

void (1,2)
pm_message (const char format[], ...);


Version-Release number of selected component (if applicable):
netpbm-10.35

How reproducible:
Always.

Additional info:
Fixed upstream, checked revision: 354, maybe earlier.
Comment 1 Jose Plans 2007-07-04 04:50:50 EDT
Created attachment 158505 [details]
netpbm-non_gnu_c_pm_h.patch
Comment 2 RHEL Product and Program Management 2007-12-03 15:43:46 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 6 RHEL Product and Program Management 2009-03-26 13:21:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 12 errata-xmlrpc 2009-09-02 05:18:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1268.html

Note You need to log in before you can comment on or make changes to this bug.