Bug 246710 - the system hang for 30 seconds waiting for the sata disk
the system hang for 30 seconds waiting for the sata disk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-04 06:31 EDT by Levente Farkas
Modified: 2013-07-02 22:33 EDT (History)
1 user (show)

See Also:
Fixed In Version: 5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 13:50:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2007-07-04 06:31:45 EDT
Description of problem:
we've got a server with 6 sata disk (2 system raid1, 4 data raid5).
recently we've got such error is the log and in these case the system is
totally hang ie. it seems to crash but after 30-40 sec is start to
working. we already 2 times replace the sata cables the problem still
arise what's more with different data disk (so not the same). we assume
it can be some kind of sata driver bug or motherboard issue?
kernel-2.6.18-8.1.6.el5.x86_64 on gigabyte ga-81955x motherboard with
SAMSUNG SP2504C disks.
----------------------------------
Jul  4 12:12:50 piros kernel: ata3.00: exception Emask 0x0 SAct 0x0 SErr
0x0 action 0x2 frozen
Jul  4 12:12:50 piros kernel: ata3.00: tag 0 cmd 0xea Emask 0x4 stat
0x40 err 0x0 (timeout)
Jul  4 12:12:50 piros kernel: ata3: soft resetting port
Jul  4 12:12:53 piros kernel: ata3: softreset failed (1st FIS failed)
Jul  4 12:12:53 piros kernel: ata3: softreset failed, retrying in 5 secs
Jul  4 12:12:58 piros kernel: ata3: hard resetting port
Jul  4 12:13:05 piros kernel: ata3: port is slow to respond, this delay
is known to occur on vacant SATA ports
Jul  4 12:13:28 piros kernel: ata3: port failed to respond (30 secs)
Jul  4 12:13:28 piros kernel: ata3: COMRESET failed (device not ready)
Jul  4 12:13:28 piros kernel: ata3: hardreset failed, retrying in 5 secs
Jul  4 12:13:33 piros kernel: ata3: hard resetting port
Jul  4 12:13:33 piros kernel: ata3: SATA link up 3.0 Gbps (SStatus 123
SControl 300)
Jul  4 12:13:33 piros kernel: ata3.00: configured for UDMA/133
Jul  4 12:13:33 piros kernel: ata3: EH complete
Jul  4 12:13:33 piros kernel: SCSI device sdc: 488397168 512-byte hdwr
sectors (250059 MB)
Jul  4 12:13:33 piros kernel: sdc: Write Protect is off
Jul  4 12:13:33 piros kernel: SCSI device sdc: drive cache: write back
----------------------------------
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Martuccelli 2007-08-10 13:50:21 EDT
This is fixed in the SATA update shipping in RHEL 5.1.
Comment 2 Levente Farkas 2007-08-11 09:30:13 EDT
when will be released?
anyway we alredy replace the sata card since even after a month there was not
even a comment on this bug:-( at least a "we're working on it" would be useful...

Note You need to log in before you can comment on or make changes to this bug.