Bug 24672 - Installation Error for RH 7.0
Installation Error for RH 7.0
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-01-22 23:34 EST by David Henderson
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-01-29 19:25:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Henderson 2001-01-22 23:34:17 EST
Receiving error message, "/usr/binanaconda" line 438, in?  intf.run (to do, test=test).  

I have downloaded the update image from RH's site and another mirror site still no Luck. I've been at this for 12 hours now..HELP!!!! 
I must have this server up and running my COB Tuesday.   

If this will help, I'm not partioning the HD to run another OS and the HD drive has no existing partions.  As a matter of fact, I did a 
low level format on my HD, still NO LUCK.  If this will help, I have 2G of HD space & 32M of memory installed.  I've done both 
custom &  server installations same BAD results.  Also, before the copying process begins, I get the message that I have low amount 
of  memory, therefore it creates the SWAP partition to continue.  

The following is the info from the dump file: 
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in __call__
    if todo.doInstall ():
  File "/tmp/updates/todo.py", line 
1638, in doInstall
  File "/tmp/updates/todo.py", line 1189, in createCdrom
    os.symlink(device, self.instPath + 
"/dev/" + cdname)
OSError: [Errno 28] No space left on device

Local variables in innermost frame:
device: hdb
list: ['hdb']
<todo.ToDo instance at 8323f80>
cdname: cdrom
count: 1

ToDo object:

Comment 1 Michael Fulbright 2001-01-24 10:32:56 EST
How large was the '/' partition you specified?
Comment 2 David Henderson 2001-01-29 14:02:09 EST
The / partition was 50M
Comment 3 David Henderson 2001-01-29 15:17:51 EST
FYI...when doing a custom installation have have the following partitions defined:
/ - 50M
/boot - 16M
/var - 200M
/home - 250
/usr - 750
/usr /local - 1082M
swap 80M

I did finally, get the automatic partition for a server installation to work, but STARTX does not work.  netcfg (control panel) is the tool that I'm 
accustomed to using for configuring my small office severs (basically an office internet connection & Samba, file server). I would like do a 
custom install, that way I know what's installed, how big the partitions are, etc....
Comment 4 Michael Fulbright 2001-01-29 19:25:32 EST
Your '/' partition should be at least 100M in size.

Try that and let me know if it works.
Comment 5 Michael Fulbright 2001-02-23 12:29:13 EST
Closing due to inactivity.

Note You need to log in before you can comment on or make changes to this bug.