Bug 246751 - semanage problem
Summary: semanage problem
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: policycoreutils   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-04 16:17 UTC by 2002september@mail.ru
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-06 15:48:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description 2002september@mail.ru 2007-07-04 16:17:40 UTC
Description of problem:
Error during login creation.

Version-Release number of selected component (if applicable):
policycoreutils-1.33.12-3.el5

How reproducible:
# semanage login -a USER_NAME

Steps to Reproduce:
1.
# semanage login -a test111
libsemanage.semanage_commit_sandbox: Error while renaming
/etc/selinux/targeted/modules/active to /etc/selinux/targeted/modules/previous.
/usr/sbin/semanage: Could not add login mapping for test111

Actual results:
# semanage login -a test111
libsemanage.semanage_commit_sandbox: Error while renaming
/etc/selinux/targeted/modules/active to /etc/selinux/targeted/modules/previous.
/usr/sbin/semanage: Could not add login mapping for test111

Expected results:
Creation new Login.

Additional info:

Comment 1 2002september@mail.ru 2007-07-06 14:05:17 UTC
SOLUTION: This problem arises because "Permission denied" error. Incorrect SE
Linux rules in standard targeted policy. Just add allow rule.

Comment 2 Daniel Walsh 2007-07-06 15:48:19 UTC
restorecon -R -v /etc/selinux/targeted

should fix the problem.

This looks like a labeling problem.


Note You need to log in before you can comment on or make changes to this bug.