Bug 246771 - Requires(post)
Requires(post)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xblast (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-04 15:08 EDT by Florian La Roche
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-04 16:25:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2007-07-04 15:08:24 EDT
Description of problem:

You should "Require(post): /usr/bin/gtk-update-icon-cache" if you use
it in the post script.

regards,

Florian La Roche



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hans de Goede 2007-07-04 16:16:33 EDT
This is NOT a bug, please read:
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets?action=show&redirect=ScriptletSnippets#head-7103f6c38d1b5735e8477bdd569ad73ea2c49bda

And esp: "Note that no dependencies should be added for this." Before mass
filing even more of these.
Comment 2 Florian La Roche 2007-07-04 16:19:50 EDT
Then this should test for the presence of the app or redirect the output
as rpms should install witout error output.

regards,

Florian La Roche
Comment 3 Hans de Goede 2007-07-04 16:25:05 EDT
The guidelines /scriptlets are clear on this, go the FPC (Fedora Packaging
Comittee) to get them changed and then start fixing all the packages yourself,
which is about as much work as filing bugs and discussing with Fedora
contributers about this.

None of my packages have an ACL, so once this is past the FPC you are free to
change them.
Comment 4 Jason Tibbitts 2007-07-04 16:32:21 EDT
This bug is completely erroneous.  The current usage is as recommended; it's
even specifically stated:
   Note that no dependencies should be added for this. 
This recommendation is well-considered.  

If you opened more tickets on this, please close them.
Comment 5 Thorsten Leemhuis 2007-07-05 00:47:05 EDT
(In reply to comment #4)
> This bug is completely erroneous.

The dep really should not be there, but I'd agree with Florian's comment in #2
-- e.g. don't show and error message (e.g. by redirect the error output or
testing for presence)

Note You need to log in before you can comment on or make changes to this bug.