Bug 246797 - Screensaver crashes X
Screensaver crashes X
Status: CLOSED DUPLICATE of bug 220629
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-04 19:22 EDT by Liam Dennehy
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-09 15:38:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log (38.14 KB, text/plain)
2007-07-04 19:22 EDT, Liam Dennehy
no flags Details
lspci -nn (2.22 KB, text/plain)
2007-07-04 19:24 EDT, Liam Dennehy
no flags Details

  None (edit)
Description Liam Dennehy 2007-07-04 19:22:45 EDT
Description of problem:
Screensaver (even preview) causes X to crash and return to GDM

Version-Release number of selected component (if applicable):
kernel-xen-2.6.20-2925.11.fc7
xorg-x11-server-Xorg-1.3.0.0-9.fc7
gnome-screensaver-2.18.2-1.fc7
xscreensaver-base-5.02-1.fc7.1

How reproducible:
Always

Steps to Reproduce:
1. System, Preferences, Personal, Look and Feel, Screensaver
2. Floating Fedora Bubbles
3. Preview
  
Actual results:
X crashes, text console visible before GDM relaunches

Expected results:
Preview of my scfreensaver

Additional info:
XOrg.0.log attached including backtrace.
Comment 1 Liam Dennehy 2007-07-04 19:22:45 EDT
Created attachment 158558 [details]
Xorg.log
Comment 2 Liam Dennehy 2007-07-04 19:24:32 EDT
Created attachment 158559 [details]
lspci -nn

lspci output for hardware
Comment 3 Mamoru TASAKA 2007-07-04 21:41:11 EDT
* Well, what is "Floating Fedora Bubbles"?
  xscreensaver{,-gl}-extras-rss does not have such desktop files
  (and actually I don't know well about gnome-screensaver).

* Are you using xscreensaver-demo or gnome-screensaver-preferences?
Comment 4 Liam Dennehy 2007-07-05 16:13:07 EDT
(In reply to comment #3)
> * Well, what is "Floating Fedora Bubbles"?

One of the screensavers, and since DRI is not working (refer to bug
http://bugs.freedesktop.org/show_bug.cgi?id=11313) and hence no direct
rendering, it looks the best. Fault occurs with (apparently) all screensavers,
this was just an example. btw, it ships with F7...

>   xscreensaver{,-gl}-extras-rss does not have such desktop files
>   (and actually I don't know well about gnome-screensaver).
> 
> * Are you using xscreensaver-demo or gnome-screensaver-preferences?

gnome-screensaver-preferences
Comment 5 Mamoru TASAKA 2007-07-05 22:21:22 EDT
Once switching to X component.
X maintainers, would you help us?
Comment 6 Adam Jackson 2007-07-09 15:38:11 EDT

*** This bug has been marked as a duplicate of 220629 ***

Note You need to log in before you can comment on or make changes to this bug.