Bug 246816 - Revisor deletes downloaded files
Revisor deletes downloaded files
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-05 02:57 EDT by Wayne Carruthers
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-05 23:27:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Carruthers 2007-07-05 02:57:33 EDT
Description of problem:

A suggestion really

Attempted to create CD set of f7 using online repository with all the updates

Left it running overnight downloading all the required files. For some reason it
 appeared to be hung on a download but was able to quit

There were 800mb of 1100mb files in the tmp directory.

When I started a new attempt I assumed (wrongly) the downloaded files would be
retained but revisor removed all the tmp directories and started from scratch

Perhaps there should be a "resume" or a "retain downloaded files" capability

Having to download all the files again is frustrating, time consuming & will
cause higher server loadings

Since I was working from an updated existing F7 system which would have the
files in yum cache perhaps add capability to get files from there ??


Version-Release number of selected component (if applicable):

2.0.4.0-1-fc7

How reproducible:




Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeroen van Meeuwen 2007-07-05 06:01:14 EDT
Added as a blocker ticket for NEXTRELEASE.

We should however delete the metadata to prevent not downloading the metadata
when a repo has been updated (use case when revisor returns an error yum cannot
find a package, someone resyncs the repo or creates new metadata and runs
revisor again).
Comment 2 Jeroen van Meeuwen 2007-07-05 09:38:15 EDT
https://hosted.fedoraproject.org/projects/revisor/ticket/206
Comment 3 Wayne Carruthers 2007-07-05 22:30:20 EDT
Thank you for allocating a task for next release

Note You need to log in before you can comment on or make changes to this bug.