Bug 24682 - Duplicate versions of MySQL after upgrade.
Duplicate versions of MySQL after upgrade.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-23 05:28 EST by lasse
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-24 20:42:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description lasse 2001-01-23 05:28:06 EST
I tried to update mysql (MySQL) with the up2date tool. with the following
command:

 up2date mysql mysql-devel mysql-server

The result was:

 file /usr/bin/isamchk from install of mysql-3.23.29-1 conflicts with file
from package MySQL-3.23.28-1
file /usr/bin/isamlog from install of mysql-3.23.29-1 conflicts with file
from package MySQL-3.23.28-1
file /usr/bin/my_print_defaults from install of mysql-3.23.29-1 conflicts
with file from package MySQL-3.23.28-1

etc.. for all the packages:


However, the update went through and I've now ended up with:

 rpm -q mysql
  mysql-3.23.22-6
 rpm -q MySQL
  MySQL-3.23.28-1

The server is a RH6.2 uppgraded to RH7.0.
Comment 1 lasse 2001-01-23 05:32:24 EST
On further inspection it seems that the problem is not related to up2date but
rather on
the RedHat upgrade procedure.

Comment 2 Nalin Dahyabhai 2001-01-24 20:42:13 EST
What is the output of "rpm -qi MySQL"?
Comment 3 Nalin Dahyabhai 2001-01-24 20:48:41 EST
Package names are case-sensitive, and I suspect that the MySQL
packages are not the ones we shipped.  Changing the mysql package's
name to MySQL would break upgrades.

Note You need to log in before you can comment on or make changes to this bug.