Bug 246820 - SELinux error while installing
Summary: SELinux error while installing
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: allegro   
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-05 08:16 UTC by Nadav Kavalerchik
Modified: 2013-07-02 23:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-06 10:03:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nadav Kavalerchik 2007-07-05 08:16:40 UTC
Description of problem:
while upgrading an earlier version with rpm -Uvh i get the following error
(which i think is related to SELinux)

rpm -Uvh --force allegro_4.2.1-2.fc7_i386.rpm
Preparing...                ########################################### [100%]
   1:allegro                ########################################### [100%]
chcon: can't apply partial context to unlabeled file
/usr/lib/allegro/4.2.1/alleg-vga.so


Version-Release number of selected component (if applicable):
4.2.1-2

How reproducible:
rpm -Uvh --force allegro_4.2.1-2.fc7_i386.rpm

Steps to Reproduce:
1.rpm -Uvh --force allegro_4.2.1-2.fc7_i386.rpm
2.
3.
  
Actual results:
Preparing...                ########################################### [100%]
   1:allegro                ########################################### [100%]
chcon: can't apply partial context to unlabeled file
/usr/lib/allegro/4.2.1/alleg-vga.so


Expected results:
Preparing...                ########################################### [100%]
   1:allegro                ########################################### [100%]


Additional info:
i was using apt-get to distribution upgrade from fc6 to fc7
(which went quite well :-)

Comment 1 Hans de Goede 2007-07-05 08:35:54 UTC
The unlabeled file error means that for some reason the original wasn't labeled
maybe because you're using apt-get (which is not supported), more likely because
you have selinux disabled. Notice that this error message is harmless in case
you've selinux disabled.

jnovy, I do think that since it is harmless we should hide it by adding 2>
/dev/null to the chcon command in the %post script, agreed?


Comment 2 Nadav Kavalerchik 2007-07-05 19:49:46 UTC
originally, i've installed it with yum. so i guess it should have been labeled.

btw. i thought that the running rpm underling yum or apt-get does the work no
matter what i use to update the system with.

i know it's now a big issue, but i thought you guys might want to smooth it out.


Comment 3 Hans de Goede 2007-07-05 20:17:20 UTC
(In reply to comment #2)
> originally, i've installed it with yum. so i guess it should have been labeled.
> 
> btw. i thought that the running rpm underling yum or apt-get does the work no
> matter what i use to update the system with.
> 

It does, which is why I wrote "maybe because you're using apt-get", with
emphasizes on the maybe.

> i know it's now a big issue, but i thought you guys might want to smooth it out.
> 

We do, thanks for reporting, but first we need to know why this happens, are you
running with selinux disabled?


Comment 4 Nadav Kavalerchik 2007-07-05 21:58:15 UTC
yes, selinux is disabled.

and btw.
i used apt-get because yum had many packedges that it couldn't upgrade so
i used apt-get to move from fc6 to fc7 (first, i tried upgrading from fc7 dvd,
but... anaconda crashed, which is a different bug :-(

Comment 5 Hans de Goede 2007-07-06 10:03:32 UTC
Thanks, that explains the error.

The next rawhide push should contain 4.2.1-3, which has the error output in this
scenario silenced (the error was already ignored).


Comment 6 Hans de Goede 2007-07-06 12:28:09 UTC
(In reply to comment #5)
> The next rawhide push should contain 4.2.1-3, which has the error output in this
> scenario silenced (the error was already ignored).
> 

Scrap that, allegro doesn't build on rawhide at the moment, see bug 247256




Note You need to log in before you can comment on or make changes to this bug.