Bug 246821 - php-imap doesn't install on RHEL4.5 because of dependency problems
php-imap doesn't install on RHEL4.5 because of dependency problems
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: php (Show other bugs)
4.5
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-05 04:25 EDT by Frank Rosendahl
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-05 08:14:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Rosendahl 2007-07-05 04:25:04 EDT
Description of problem:

Unresolvable chain of dependencies:
php-imap-4.3.9-3.22.5                    requires php = 4.3.9-3.22.5

-> Installed php-Version: php-4.3.9-3.24

Version-Release number of selected component (if applicable):

4.3.9-3.22.5

How reproducible:

registering zu RHN
then up2date php-imap

Steps to Reproduce:

  
Actual results:


[root@groupware html]# up2date php-imap php

Fetching Obsoletes list for channel: rhel-i386-es-4...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
php-imap                                4.3.9          3.22.5            i386


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
php-imap-4.3.9-3.22.5                    requires php = 4.3.9-3.22.5

Expected results:

installing the right version

Additional info:
Comment 1 Joe Orton 2007-07-05 06:56:01 EDT
Is this an upgrade from an older release?  Please post the output of:

rpm -qa  | grep php
Comment 2 Frank Rosendahl 2007-07-05 07:32:58 EDT
It's a new installation of a virtuell machine with the installation set of 
RHEL4.5. After installation the machine had been connected to the RHN and 
updated. Then I tried to install the php-imap package.

Btw. the installation of squirrelmail doesn't work to, because it depends on 
php-mbstring-4.3.9-3.22.5 which requires php = 4.3.9-3.22.5.

Here my output:

[root@groupware html]# rpm -qa | grep php
php-ldap-4.3.9-3.24
php-4.3.9-3.24
php-mysql-4.3.9-3.24
php-pgsql-4.3.9-3.24
php-pear-4.3.9-3.24
Comment 3 Joe Orton 2007-07-05 08:14:59 EDT
The version of the php which shipped in 4.5 was php-4.3.9-3.22.4.  The -3.24
packages have not been released via Red Hat Network nor in shipping media AFAIK,
so I'm not sure where you got them from.

To resolve this, download all the necessary the -3.22.5 packages using "up2date
--download" then upgrade using:

  # rpm -Uvh --oldpackage php*.rpm

Note You need to log in before you can comment on or make changes to this bug.