Bug 246825 - Add alpha to supported archs in net-snmp-config - patch (untested) included
Summary: Add alpha to supported archs in net-snmp-config - patch (untested) included
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: net-snmp   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jan Safranek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-05 10:27 UTC by Oliver Falk
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 08:37:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Oliver Falk 2007-07-05 10:27:13 UTC
Index: net-snmp-config
===================================================================
RCS file: /cvs/pkgs/devel/net-snmp/net-snmp-config,v
retrieving revision 1.1
diff -u -p -r1.1 net-snmp-config
--- net-snmp-config     25 May 2006 10:22:39 -0000      1.1
+++ net-snmp-config     5 Jul 2007 10:25:48 -0000
@@ -11,7 +11,7 @@
 # this particular shell script calls arch specific script to avoid
 # multilib conflicts
 
-# Supported arches ix86 ia64 ppc ppc64 s390 s390x x86_64
+# Supported arches ix86 ia64 ppc ppc64 s390 s390x x86_64 alpha
 
 arch=`arch`
 echo $arch | grep -q i.86
@@ -44,4 +44,9 @@ if [ "$arch" = "x86_64" ] ; then
     exit 0
 fi
 
+if [ "$arch" = "alpha" ] ; then
+    net-snmp-config-alpha $*
+    exit 0
+fi
+
 echo "Cannot determine architecture"
Index: net-snmp.spec
===================================================================
RCS file: /cvs/pkgs/devel/net-snmp/net-snmp.spec,v
retrieving revision 1.117
diff -u -p -r1.117 net-snmp.spec
--- net-snmp.spec       28 Jun 2007 10:21:58 -0000      1.117
+++ net-snmp.spec       5 Jul 2007 10:25:49 -0000
@@ -7,7 +7,7 @@
 Summary: A collection of SNMP protocol tools and libraries
 Name: net-snmp
 Version: %{major_ver}
-Release: 15%{?dist}
+Release: 15.1axp%{?dist}
 Epoch: 1
 
 License: BSDish
@@ -372,6 +372,9 @@ rm -rf ${RPM_BUILD_ROOT}
 %{_libdir}/lib*.so.*
 
 %changelog
+* Thu Jul 05 2007 Oliver Falk <oliver@linux-kernel.at> 5.4-15.1axp
+- Add alpha to supported archs in net-snmp-config
+
 * Thu Jun 28 2007 Jan Safranek <jsafranek@redhat.com> 5.4-15
 - fix default snmptrapd.conf

Comment 1 Jan Safranek 2007-08-01 06:42:59 UTC
net-snmp-1:5.4-16.fc8 should be compilable on alpha. Since I do not have any
such  machine here, I would like to ask you to test the build and functionality.

Comment 2 Oliver Falk 2007-08-01 07:19:00 UTC
I start the build now and let you know.


Note You need to log in before you can comment on or make changes to this bug.