Bug 246828 - Problem building m2crypto on alpha due to multilib fix
Problem building m2crypto on alpha due to multilib fix
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: m2crypto (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-05 06:39 EDT by Oliver Falk
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.17-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 18:04:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-07-05 06:39:11 EDT
I'm not 100% sure if this patch will help - not yet tested - but I hope.

Index: m2crypto.spec
===================================================================
RCS file: /cvs/pkgs/devel/m2crypto/m2crypto.spec,v
retrieving revision 1.33
diff -u -p -r1.33 m2crypto.spec
--- m2crypto.spec       26 Apr 2007 23:05:18 -0000      1.33
+++ m2crypto.spec       5 Jul 2007 10:37:02 -0000
@@ -3,7 +3,7 @@
 Summary: Support for using OpenSSL in python scripts
 Name: m2crypto
 Version: 0.17
-Release: 2
+Release: 2.1axp%{?dist}
 Source0:
http://wiki.osafoundation.org/pub/Projects/MeTooCrypto/m2crypto-%{version}.tar.gz
 Patch0: m2crypto-0.17-timeouts.patch
 Patch1: m2crypto-0.17-Py_ssize_t.patch
@@ -33,7 +33,9 @@ basearch=%{_arch}
 %ifarch %{ix86}
 basearch=i386
 %endif
+%ifnarch alpha
 sed -i -e "s/opensslconf/opensslconf-${basearch}/" SWIG/_ec.i
+%endif
 
 %build
 CFLAGS="$RPM_OPT_FLAGS" ; export CFLAGS
@@ -73,6 +75,9 @@ rm -rf $RPM_BUILD_ROOT
 %{python_sitearch}/M2Crypto
 
 %changelog
+* Thu Jul 05 2007 Oliver Falk <oliver@linux-kernel.at> - 0.17-2.1axp
+- Fix multilib issue on alpha, where no multilib exists
+
 * Fri Apr 27 2007 Miloslav Trmac <mitr@redhat.com> - 0.17-2
 - Make m2xmlrpclib work with Python 2.5
   Resolves: #237902
Comment 1 Miloslav Trmač 2007-07-11 18:04:02 EDT
Should be fixed in rawhide m2crypto-0.17-3.  Thanks for your report.
Comment 2 Oliver Falk 2007-07-17 03:33:20 EDT
For me this works. Thx!

Note You need to log in before you can comment on or make changes to this bug.