Bug 246842 - Review the udev rules
Review the udev rules
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ctapi-cyberjack (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Frank Büttner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-05 08:01 EDT by Harald Hoyer
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.0.3-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-06 13:55:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2007-07-05 08:01:44 EDT
udev has changed the rule syntax.
See /usr/share/doc/udev-*/RELEASE-NOTES and man udev(7)

Please review your udev rules and change:
BUS -> SUBSYSTEMS, ID -> KERNELS, SYSFS -> ATTRS, DRIVER -> DRIVERS

Thanks
Comment 1 Frank Büttner 2007-08-04 14:56:34 EDT
Thanks,
fixed at devel.
Comment 2 Michael Schwendt 2007-08-04 16:15:02 EDT
Unless I miss something, these changes won't work in
Fedora 6 (udev 095) as udev >= 098 is required. Pushing this
update to Fedora 6 would break, wouldn't it?

http://buildsys.fedoraproject.org/build-status/job.psp?uid=35443
Comment 3 Frank Büttner 2007-08-05 04:56:48 EDT
I have look at the man pages of FC6 and there are the same options.
But I will test it again.
Comment 4 Michael Schwendt 2007-08-05 05:46:14 EDT
> I have look at the man pages of FC6 and there are the same options.

Cannot confirm.

$ rpm -q udev
udev-095-17.fc6
Comment 5 Frank Büttner 2007-08-05 05:57:19 EDT
take a look at man udev 7 at FC6 you will see the same option(of that I use).
Comment 6 Michael Schwendt 2007-08-05 06:19:17 EDT
> +SUBSYSTEMS=="usb", ATTRS{idVendor}=="0c4b"

In F6 "man udev" there is no SUBSYSTEMS, only SUBSYSTEM, and no
ATTRS either.
Comment 7 Harald Hoyer 2007-08-06 05:18:52 EDT
this change is only intended for "devel" and maybe F7... never said s.th. about
FC-6 ...
Comment 8 Harald Hoyer 2007-08-06 05:24:53 EDT
also please check the groups, either add the missing groups in the %post
section, or remove it from the udev rules.
Comment 9 Frank Büttner 2007-08-06 13:04:58 EDT
The group will be exits, because of the group require.
And the common package will provide it.
Comment 10 Fedora Update System 2007-08-06 13:55:15 EDT
ctapi-cyberjack-3.0.3-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.