Bug 247172 - firefox-plugin.pc missing -I${includedir}
firefox-plugin.pc missing -I${includedir}
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-05 15:45 EDT by Alexandre Oliva
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 08:17:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2007-07-05 15:45:00 EDT
Can't built GCC 4.2 or 4.3 with GCJ Web Plugin enabled because pkgconfig
--cflags firefox-plugin doesn't list the directory containing nsISupports.h,
included from various files in /usr/include/firefox-2.0.0.4/plugin

Version-Release number of selected component (if applicable):
firefox-2.0.0.4-2.fc7
Comment 1 Christopher Aillon 2007-07-05 16:25:07 EDT
You're supposed to also use pkgconfig --cflags firefox-xpcom to build if you
need nsISupports.
Comment 2 Alexandre Oliva 2007-07-05 16:54:20 EDT
I don't know that I need nsISupports.  It's just that some header files in
plugin/ include nsISupports.h.  Therefore, firefox-plugin might as well be
helpful and provide the additional needed -I flags.  Otherwise it becomes
necessary to always use firefox-xpcom cflags after firefox-plugin.

Oddly, the #includes are "", not <>, so it even looks like nsISupports.h was
expected to be in the same directory as the plugin headers.  Is this some
packaging error?
Comment 3 Christopher Aillon 2007-07-05 17:49:28 EDT
(In reply to comment #2)
> I don't know that I need nsISupports.  It's just that some header files in
> plugin/ include nsISupports.h.  Therefore, firefox-plugin might as well be
> helpful and provide the additional needed -I flags.  Otherwise it becomes
> necessary to always use firefox-xpcom cflags after firefox-plugin.

Only the nsI* files require nsISupports (and thus require xpcom).  If you're
only including the np* stuff for the basic NPAPI support, you don't need to pull
in the rather heavy xpcom dependency.  This behavior is intentional from
upstream.  See https://bugzilla.mozilla.org/show_bug.cgi?id=366113


> Oddly, the #includes are "", not <>, so it even looks like nsISupports.h was
> expected to be in the same directory as the plugin headers.  Is this some
> packaging error?

This is how upstream ships it.
Comment 4 Martin Stransky 2007-09-11 08:17:47 EDT
Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.