Bug 247212 - perl-Bit-Vector-6.4-3.fc8 provides are messed up
Summary: perl-Bit-Vector-6.4-3.fc8 provides are messed up
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Bit-Vector   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-06 00:53 UTC by Jonathan Kamens
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-06 18:29:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2007-07-06 00:53:30 UTC
$ rpm -q --provides -p perl-Bit-Vector-6.4-3.fc8.i386.rpm 
Vector.so  
perl(Bit::Vector::Overload) = 6.4
perl(Bit::Vector::String) = 6.4
perl-Bit-Vector = 6.4-3.fc8
$ rpm -q perl-Bit-Vector
perl-Bit-Vector-6.4-2.2.2.1
$ rpm -q --provides perl-Bit-Vector
Vector.so  
perl(Bit::Vector)  
perl(Bit::Vector) = 6.4
perl(Bit::Vector::Overload) = 6.4
perl(Bit::Vector::String) = 6.4
perl-Bit-Vector = 6.4-2.2.2.1
$ 

Note the differences in what's provided by the installed perl-Bit-Vector vs.
what's provided by the current devel package.

Comment 1 Robin Norwood 2007-07-06 18:29:23 UTC
Thanks for catching this.  It was caused by a botched attempt to removed the
unversioned provides: perl(Bit::Vector), which is bad.  The versioned one should
of course stay - "perl(Bit::Vector) = 6.4"

Fixed in 6.4-4.fc8:

rpm -qp --provides
/home/rnorwood/cvs/fedora/perl-Bit-Vector/devel/i386/perl-Bit-Vector-6.4-4.fc8.i386.rpm
Vector.so  
perl(Bit::Vector) = 6.4
perl(Bit::Vector::Overload) = 6.4
perl(Bit::Vector::String) = 6.4
perl-Bit-Vector = 6.4-4.fc8



Note You need to log in before you can comment on or make changes to this bug.