Bug 247238 - Installer does not detect RAID/Sata disks on Ati SB600 south bridge
Installer does not detect RAID/Sata disks on Ati SB600 south bridge
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Prarit Bhargava
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-06 04:25 EDT by Mehmet ALLAR
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-17 09:44:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mehmet ALLAR 2007-07-06 04:25:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.13) Gecko/20060414

Description of problem:
I have upgraded my PC with Asus M2A-VM mobo and 2 Seagate SATA2 disks at Raid0 (stripe ) config. i've installed XP and XP64 on these disks without any problems. 
but Fedora 7 installation hangs while " Loading AHCI driver " screen for 5~6 minutes, then goes on . but in installation there is no HDD detected .

Mobo is M2A-VM with ATI SB600 southbridge .

best regards

Version-Release number of selected component (if applicable):
Fedora 7

How reproducible:
Always


Steps to Reproduce:
1.run F7 DVD on boot
2.freezes on " Loading AHCI driver " for 5~6 minutes with HDD led on
3.no HDD detected on installation screen

Actual Results:
no HDD detected on installation screen .

Expected Results:
i should have seen my Partitioned drives instead.

Additional info:
detailed System info trying to install :

AMD 5200+ Athlon x2 CPU
Asus M2A-VM mainboard (bios version 0801 - latest atm) with AMD 690G north and Ati sb600 Southbridge.
2x Seagate ST380815AS disks at bios Raid array config (stripe)
Comment 1 Prarit Bhargava 2007-07-11 14:20:51 EDT
Could you grab a recent fedora devel kernel and retest?

Thanks,

P.
Comment 2 Prarit Bhargava 2007-07-12 14:10:30 EDT
Mehmet, you can grab a kernel from one of the sites listed here:

http://mirrors.fedoraproject.org/publiclist/Fedora/7/

Install the kernel rpm package and reboot -- does your system boot?

Thanks,

P.
Comment 3 Mehmet ALLAR 2007-07-13 05:59:36 EDT
nope, my system does not boot yet, because i couldn't hve installed Fedora yet .
The installer (anaconda) does not detect my raid drives on this south bridge ,
so i can't install Fedora. I need an updated re-spin of the DVD , or rescue CD
preferably.
Comment 4 Prarit Bhargava 2007-07-17 09:39:33 EDT
boot.iso from here should work ftp://fedora.bu.edu/fedora/development/x86_64/os

P.
Comment 5 Prarit Bhargava 2007-07-17 09:44:59 EDT
WFM with latest fedora, kernel-2.6.23-0.15.rc0.git1.fc8.x86_64.rpm .  As
previously mentioned, upstream had a lot of SB600 churn.

P.
Comment 6 Mehmet ALLAR 2007-07-31 03:10:26 EDT
(In reply to comment #4)
> boot.iso from here should work ftp://fedora.bu.edu/fedora/development/x86_64/os
> 
> P.

it did not . the new boot.iso refused working, it hangs in the options screen ,
where F1/F2 and so on can be selected/pressed . 

and new FC8 kernel installation on FC7 also did not work , it freezes where it
loads the kernel in the boot up . (on normal ide installation for testing) 
Comment 7 Mehmet ALLAR 2007-07-31 03:14:06 EDT
just as a side note : to my surprise , Fedora 7 (32 bit ) version installation
recogized disks on Ati SB600 controller, but seperately. and deleted my data on
the disks with wrong clicking, due to invalid partition table it couln't
recognize . It detects the disks on the controller , but does not support bios
raid function . 

Note You need to log in before you can comment on or make changes to this bug.