Bug 247240 - CRM #1595438 - rhnapi docs page contains incorrect banner and sidebar
CRM #1595438 - rhnapi docs page contains incorrect banner and sidebar
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
low Severity low
: ---
: ---
Assigned To: Grant Gainey
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-06 04:41 EDT by Issue Tracker
Modified: 2010-10-22 12:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: 5.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-05 09:50:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2007-07-06 04:41:10 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2007-07-06 04:41:14 EDT
Description of problem:

The apidocs page on RHN hosted website contains a header bar and side bar that is often from the last page.  It is rarely correct.  This ticket was requested to be filed by Justin Sherrill.  Here is an example screenshot: 
 
http://mesonet.agron.iastate.edu/pickup/ss4.png

How reproducible:
Always

Steps to Reproduce:

If you login to rhn, click "Channels->help->api"  the api page will show the "channels" side bar and top bar.

If you login and click "systems->help->api" the page will display the "Systems" side bar and top bar.  

Actual results:
It shows the header and side bar from the previous page.

Expected results:
It should show the help page's side bar and top bar but does not.

Additional info:
This event sent from IssueTracker by vgaikwad  [SEG - RHN]
 issue 125616
Comment 2 Issue Tracker 2007-07-06 04:41:17 EDT
Since this issue persists on RHN SATs also, I had a look at
/var/lib/tomcat5/webapps/rhn/apidoc/index.jsp which just prints the body.
So probably we need to include the correct Left Side bar (sidenav) on this
page like other jsp pages do.


This event sent from IssueTracker by vgaikwad  [SEG - RHN]
 issue 125616
Comment 3 Grant Gainey 2007-07-13 13:59:01 EDT
Actually, this feels like a Perl/Java session mismatch issue.  Currently on
505triage, will evaluate for earlier inclusion.
Comment 4 Issue Tracker 2007-07-27 05:29:53 EDT
Customer has reported the following:

With the 5.0.2 rollout last night, the API docs page is now completely
missing. 

https://rhn.redhat.com/rhn/apidoc/ -> Returns 'Page Not Found'

Regards,



This event sent from IssueTracker by vgaikwad 
 issue 125616
Comment 6 Grant Gainey 2007-08-09 08:18:50 EDT
Fixing the original problem isn't assigned to a release yet.  

The docs issue was fixed earlier this week; I'm looking at
https://rhn.redhat.com/rhn/apidoc/ right now, in fact.

The missing docs was the result of some process changes; the hole's been fixed
so that it doesn't happen again.  Apologies to the customer for the temporary
disappearance!
Comment 7 Justin Sherrill 2007-08-13 10:26:32 EDT
Hi,

Just FYI, this was fixed on the satellite side in revision 119146:

http://svn.rhndev.redhat.com/viewcvs?rev=119146&view=rev

-Justin
Comment 8 Justin Sherrill 2007-08-13 15:39:18 EDT
Also, revision 119149 is also of use (that is a more proper way of making all of
the handler pages show the bar as well).

Justin
Comment 10 Amy Owens 2008-06-05 09:50:01 EDT
this seems to be closed

Note You need to log in before you can comment on or make changes to this bug.