Bug 247247 - Conflicting Provides
Summary: Conflicting Provides
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-XML-Twig   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-06 11:07 UTC by Michael Schwendt
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-08 04:35:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2007-07-06 11:07:15 UTC
perl-XML-Twig provides perl(XML::XPathEngine::NodeSet)
perl-XML-XPathEngine provides perl(XML::XPathEngine::NodeSet)
  required by: perl-XML-XPathEngine - 0.08-1.fc7.noarch

Indeed:

$ sudo yum install 'perl(XML::XPathEngine::NodeSet)'

does not install perl-XML-XPathEngine, but perl-XML-Twig.

[...]

Further reference, similar cases:
https://www.redhat.com/archives/fedora-perl-devel-list/2007-July/msg00011.html

Comment 1 Robin Norwood 2007-07-08 04:35:01 UTC
Yep, this Provides is bogus.  XML::Twig does some funny business overriding
methods in XML::XPathEngine::Nodeset, which confuses rpm.

fixed in perl-XML-Twig-3.29-4.fc8

Comment 2 Alex Lancaster 2007-07-11 03:07:41 UTC
(In reply to comment #1)
> Yep, this Provides is bogus.  XML::Twig does some funny business overriding
> methods in XML::XPathEngine::Nodeset, which confuses rpm.
> 
> fixed in perl-XML-Twig-3.29-4.fc8

Thanks, good to hear that the problem isn't with the perl-XML-XPathEngine
package... ;)


Note You need to log in before you can comment on or make changes to this bug.