Bug 247275 - syncing imcremental dumps on disconnected satellites unlinks existing packages from rhnchannelpackage
syncing imcremental dumps on disconnected satellites unlinks existing package...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
unspecified
All Linux
medium Severity high
: ---
: ---
Assigned To: Pradeep Kilambi
wes hayutin
:
Depends On:
Blocks: 254206
  Show dependency treegraph
 
Reported: 2007-07-06 12:11 EDT by Pradeep Kilambi
Modified: 2007-08-29 11:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat501
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 11:34:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to skip package clean up while importing channel dumps (1.32 KB, text/x-patch)
2007-07-06 12:44 EDT, Pradeep Kilambi
no flags Details

  None (edit)
Description Pradeep Kilambi 2007-07-06 12:11:13 EDT
Description of problem:

Syncing Incremental dumps on disconnected satellites unlinks all the existing
packages that are not in the dump to be unlinked. This is because of the cleanup
action we usually take to make sure obsoletes removed from hosted channels dont
remain in the channel. But this wont work for Incremental dumps. The strict
option passed to backend.subscribeToChannel method pretty much enables the cleanup. 

We should probably just default to not restrict for disconnected satellites in
general.
Comment 1 Pradeep Kilambi 2007-07-06 12:44:12 EDT
Created attachment 158669 [details]
patch to skip package clean up while importing channel dumps
Comment 3 Pradeep Kilambi 2007-08-15 08:13:33 EDT
This is scheduled to be released for sat-5.1.0. If this is turning out to be a
critical issue and customers are expecting it earlier let me know and I'll to
escalate it up for any maintenance release we might have earlier.


Comment 4 Pradeep Kilambi 2007-08-15 13:14:36 EDT
good news..\this will be release as a part of 5.0.1 maintenance release,
fix committed
Transmitting file data ..
Committed revision 119206.
Comment 6 Pradeep Kilambi 2007-08-17 09:43:18 EDT
testplan:
 1. setup a disconnected sat
 2. sync a base channel say rhel-i386-4-as
 3. now sync an incremental dump for the same..
 so say afetr you synced the base you imported ~2k packages
 and the incremental will have much lesser say 500~
 after you sync the incremental it should not remove the ~2k packages synced
previously..
Comment 7 Steve Salevan 2007-08-17 13:46:25 EDT
The incremental dump sync kept the same amount of packages and did not delete
any of the packages that I synced earlier.  As a result, it looks like I can no
longer reproduce this bug and I'm moving it to VERIFIED as a result.
Comment 8 wes hayutin 2007-08-27 18:39:15 EDT
release pending 

Summary:  	Red Hat Enterprise Linux AS (v. 4 for 32-bit x86)
Description: 	Red Hat Enterprise Linux AS (v. 4 for 32-bit x86)
Label: 	rhel-i386-as-4
Last Modified: 	2007-08-27 18:27:09 EDT
Channel Entitlement Name: 	Red Hat Enterprise Linux (core server)
Parent Channel: 	(none)
Architecture: 	IA-32
Packages: 	4506
Globally Subscribable: 	All users in your organization may subscribe to this
channel.
Systems Subscribed: 	


After Errata Incremental sync

Summary:  	Red Hat Enterprise Linux AS (v. 4 for 32-bit x86)
Description: 	Red Hat Enterprise Linux AS (v. 4 for 32-bit x86)
Label: 	rhel-i386-as-4
Last Modified: 	2007-08-27 18:37:00 EDT
Channel Entitlement Name: 	Red Hat Enterprise Linux (core server)
Parent Channel: 	(none)
Architecture: 	IA-32
Packages: 	4508
Globally Subscribable: 	All users in your organization may subscribe to this
channel.
Systems Subscribed: 	1

Note You need to log in before you can comment on or make changes to this bug.