Bug 247295 - Azureus crashes when entering port number
Summary: Azureus crashes when entering port number
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: azureus   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Anthony Green
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-06 18:36 UTC by Marek Mahut
Modified: 2008-01-15 23:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 17:07:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
azureus logs (174.49 KB, application/x-gzip)
2007-07-06 18:45 UTC, Marek Mahut
no flags Details

Description Marek Mahut 2007-07-06 18:36:59 UTC
Description of problem:

Azureus crashes when I try to change the port number.

Version-Release number of selected component (if applicable):

azureus-2.5.0.4-2.fc7

How reproducible:

always

Steps to Reproduce:
1. open azureus
2. "utils" -> "nat"
3. try to change the port number
  
Actual results:

Crash of azureus.

Expected results:

Azureus changes the port number.

Additional info:

[zuzka@storm ~]$ azureus 
DEBUG::Fri Jul 06 20:27:53 GMT+02:00
2007::org.gudy.azureus2.core3.security.impl.SESecurityManagerImpl::initialise::-1:
  No SSL provider available
   
SESecurityManager::initialise::-1,ConfigurationChecker::setSystemProperties::-1,ConfigurationManager::initialise::-1,ConfigurationManager::getInstance::-1,LoggerImpl::init::-1,Logger::<clinit>::-1,Class::initializeClass::-1,Logger::isEnabled::-1,StartServer::<init>::-1,Main::<init>::-1,Main::main::-1
changeLocale: *Default Language* != fr (BE). Searching without country..
changeLocale: Searching for language fr in *any* country..
changeLocale: no message properties for Locale 'fr (BE)' (fr_BE), using 'fr (FR)'
DEBUG::Fri Jul 06 20:27:55 GMT+02:00
2007::org.gudy.azureus2.core3.security.impl.SESecurityManagerImpl::initialise::-1:
  No SSL provider available
   
SESecurityManager::initialise::-1,CryptoManagerImpl::<init>::-1,CryptoManagerImpl::getSingleton::-1,CryptoManagerFactory::getSingleton::-1,AzureusCoreImpl::<init>::-1,AzureusCoreImpl::create::-1,AzureusCoreFactory::create::-1,Main::<init>::-1,Main::main::-1

***MEMORY-WARNING***: [7635]: GSlice: g_thread_init() must be called before all
other GLib functions; memory corruption due to late invocation of
g_thread_init() has been detected; this program is likely to crash, leak or
unexpectedly abort soon...
GTK Accessibility Module initialized
DEBUG::Fri Jul 06 20:28:05 GMT+02:00
2007::com.aelitis.azureus.core.impl.AzureusCoreImpl$8::runSupport::-1:
  java.lang.NullPointerException
   at org.gudy.azureus2.ui.swt.updater2.SWTUpdateChecker.initialize(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.mainwindow.Initializer$4.started(Azureus2.jar.so)
   at com.aelitis.azureus.core.impl.AzureusCoreImpl$8.runSupport(Azureus2.jar.so)
   at org.gudy.azureus2.core3.util.AEThread.run(Azureus2.jar.so)

DEBUG::Fri Jul 06 20:28:07 GMT+02:00
2007::com.aelitis.azureus.core.networkmanager.impl.tcp.VirtualChannelSelectorImpl::select::-1:
  VirtualChannelSelector: No progress for op 1: listener = class
com.aelitis.azureus.core.clientmessageservice.impl.NonBlockingReadWriteService$2,
count = 10, socket: open = true, connected = true
   
VirtualChannelSelector::select::-1,NonBlockingReadWriteService$1::runSupport::-1,AEThread::run::-1
DEBUG::Fri Jul 06 20:28:16 GMT+02:00
2007::com.aelitis.azureus.core.networkmanager.impl.tcp.VirtualChannelSelectorImpl::select::-1:
  VirtualChannelSelector: No progress for op 1: listener = class
com.aelitis.azureus.core.clientmessageservice.impl.NonBlockingReadWriteService$2,
count = 100, socket: open = true, connected = true
   
VirtualChannelSelector::select::-1,NonBlockingReadWriteService$1::runSupport::-1,AEThread::run::-1
/usr/bin/azureus: line 18:  7635 Abandon                
LD_LIBRARY_PATH=/usr/lib/eclipse:/usr/lib
CLASSPATH=/usr/lib/eclipse/swt-gtk-3.2.jar:`build-classpath bcprov
jakarta-commons-cli log4j gtk2.8 glib0.2`:/usr/share/azureus/Azureus2.jar java
-Dgnu.gcj.runtime.VMClassLoader.library_control=never
-Dazureus.install.path=$APPDIR org.gudy.azureus2.ui.swt.Main "$@"
[zuzka@storm ~]$

Comment 1 Marek Mahut 2007-07-06 18:45:34 UTC
Created attachment 158689 [details]
azureus logs

Comment 2 Lillian Angel 2007-12-03 17:07:42 UTC
Updated to azureus-3.0.3.4-1.fc9. 
Should be available tomorrow in rawhide.

Comment 3 Fedora Update System 2008-01-15 23:04:41 UTC
azureus-3.0.3.4-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.