Bug 247317 - Include resize2fs on rescue disk
Include resize2fs on rescue disk
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: David Lehman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-06 16:53 EDT by Peter Larsen
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 14:13:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Larsen 2007-07-06 16:53:52 EDT
Description of problem:
When loading linux rescue, resize2fs isn't included. This tool is important when
fixing disk space issues, for instance to move space between LVMs.

Version-Release number of selected component (if applicable):


How reproducible:
Load linux rescue. Say no to network and to mounting existing system. resize2fs
isn't available.
Comment 1 Chris Lumens 2007-08-30 16:42:19 EDT
There's no /sbin/resize2fs on your rescue image?  What method are you using -
cd, http, ftp, etc.?
Comment 2 Peter Larsen 2007-08-30 16:54:23 EDT
(In reply to comment #1)
> There's no /sbin/resize2fs on your rescue image?  What method are you using -
> cd, http, ftp, etc.?

?? I'm in recovery mode because I need to resize a partition (root) but there is
no tools on the recovery image to do that (resize2fs is one common tool to do
this). I had to setup my own recovery media that included a tool to resize
filesystems (ext2/ext3).

I hope this clarified it?
Comment 3 Chris Lumens 2007-08-30 17:05:16 EDT
The rescue media can come as a CD, or you can add "linux rescue" on pxe network
parameters to specify that the rescue image should come from a different
location.  These different locations mean slightly different file lists.
Comment 4 David Lehman 2007-09-07 15:02:48 EDT
I have verified the presence of /usr/sbin/resize2fs in both i386 RHEL4-U5 rescue
environment images. What architecture are you seeing this behavior on? Are you
using a Red Hat Enterprise Linux installation CD or are you booting through some
other means such as PXE or a boot disk?

Comment 5 Peter Larsen 2007-09-17 13:37:26 EDT
RHEL4 U1 it wasn't included?? If it's been fixed in the later updates, that's
great :)  But since I didn't find it on Fedora's rescue, I thought it was a
systemic issue.

I used the CD directly.
Comment 6 David Lehman 2007-09-17 14:13:28 EDT
I see /usr/sbin/resize2fs in the RHEL4-U1 stage2 image, and in Fedora 7 as well.
I see in the CVS logs that it has been part of all cdrom rescue environment
images since December of 2002. If you feel there is in fact something missing,
please open a ticket with Red Hat support.

Note You need to log in before you can comment on or make changes to this bug.