Bug 24732 - saving of multiport rules broken
saving of multiport rules broken
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: iptables (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-23 14:39 EST by Enrico Scholz
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-24 10:28:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-01-23 14:39:39 EST
When creating a rule like:

| iptables -I INPUT -p tcp -m multiport --destination-port 1 -j ACCEPT

the save command dumps core:

$ iptables-save
# Generated by iptables-save v1.2 on Tue Jan 23 13:44:31 2001
*filter
:INPUT ACCEPT [9:504]
Segmentation fault (core dumped)


Tested with final 2.4.0 kernel and kernel-2.4.0-0.43.12 package.
Comment 1 Bernhard Rosenkraenzer 2001-01-24 09:33:07 EST
Debugging. Traced down to iptables-save.c:110 so far...
Comment 2 Enrico Scholz 2001-01-24 10:07:00 EST
The netfilter-maillist contains some patches for the save-function. Perhaps in
their CVS it is already solved...
Comment 3 Bernhard Rosenkraenzer 2001-01-24 10:28:41 EST
It comes down to multiport not providing a save method.
Should be
	if(match->save)
		match->save(...)
rather than just
	match->save(...)
Comment 4 Bernhard Rosenkraenzer 2001-01-24 10:32:38 EST
Fixed in 1.2.0-4.

Note You need to log in before you can comment on or make changes to this bug.