Bug 247350 - kernel boot parameter libata.pata_dma=0 does not work in kernel-2.6.21-1.3255.fc7
kernel boot parameter libata.pata_dma=0 does not work in kernel-2.6.21-1.3255...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-07 09:50 EDT by Mihai Harpau
Modified: 2008-01-09 12:22 EST (History)
1 user (show)

See Also:
Fixed In Version: F8-final
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 10:55:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mihai Harpau 2007-07-07 09:50:46 EDT
Description of problem:

Disabling DMA for PATA optical drives does not work in F7
Version-Release number of selected component (if applicable):

kernel-2.6.21-1.3255.fc7

How reproducible:

put libata.pata_dma=0 parameter on kernel boot line in grub.conf
  
Actual results:

Unknown boot option `libata.pata_dma=0': ignoring

Expected results:

have a PATA DVD in PIO mode
Additional info:
Comment 1 Chuck Ebbert 2007-07-09 11:57:37 EDT
Please try "pata_dma=0"
Comment 2 Mihai Harpau 2007-07-09 13:15:24 EDT
After I boot with pata_dma=0 parameter I don't have again the message "Unknown
boot option ...". However DMA is not disabled for PATA optical device.
After more findings I found out that what work is to put the following line
"options libata pata_dma=0" in /etc/modprobe.conf, remake initrd image and boot
with new initrd.
Comment 3 Christopher Brown 2007-09-17 17:08:37 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

This bug appears to be resolved and I am therefore closing it. If I have erred,
please forgive me and re-open with any additional information you are able to
give. I will then try and assist you if I can.

Cheers
Chris
Comment 4 Mihai Harpau 2007-09-18 03:26:28 EDT
No, this bug is not fixed in kernel kernel-2.6.22.5-76.fc7 (neither in
kernel-2.6.22.4-65.fc7).
Comment 5 Christopher Brown 2007-09-18 05:50:40 EDT
Okay, sorry to hear it Mihai. However you will be glad to read the following:

http://www.redhat.com/archives/fedora-kernel-list/2007-September/msg00011.html

therefore I would be grateful if you could test with a rawhide kernel and report
back.

Cheers
Chris
Comment 6 Chuck Ebbert 2007-09-18 10:15:34 EDT
The new pata_dma patch is also in F7 kernel 2.6.22.6-81, which is now in the
updates-testing repository.
Comment 7 Christopher Brown 2007-09-18 10:26:38 EDT
Mihai, can you test please and close if fixed for you.

Cheers
Chris
Comment 8 Mihai Harpau 2007-09-18 11:52:50 EDT
Sorry neither F7 kernel 2.6.22.6-81 from updates-testing repository does not work.
I will try a rawhide kernel as soon as I can.
Comment 9 Mihai Harpau 2007-09-18 12:25:56 EDT
The same with last rawhide kernel 2.6.23-0.185.rc6.git7.fc8
Comment 10 Christopher Brown 2007-09-18 16:38:08 EDT
In what way do these not work? The bug was filed indicates that the boot parameter:

libata.pata_dma=0

does not work. Is this really still the case?
Comment 11 Chuck Ebbert 2007-09-18 17:22:27 EDT
Apparently you need to add the parameter to the module when it gets loaded, like
in comment #2. This makes it pretty useless for distro installs unless libata is
built into the kernel...
Comment 12 Mihai Harpau 2007-09-19 05:40:15 EDT
Ref comment #10: yes the bug is still present in all that kernels
Comment 13 Mihai Harpau 2007-09-19 05:44:52 EDT
Ref comment #11: also this is problem if you want to upgrade firmware for a DVD
with a LiveCD/LiveDVD booted externally
Comment 14 Chuck Ebbert 2007-09-19 15:44:50 EDT
Yeah, without support in anaconda this parameter is pretty much useless. And
since upstream hasn't decided exactly how it will work yet, it should probably
just be removed.
Comment 15 Christopher Brown 2008-01-09 10:55:17 EST
This option was made available for F8 release final with support for anaconda. I
am therefore closing this bug to reflect that. Please re-open if current kernels
do not perform correctly for you.
Comment 16 Chuck Ebbert 2008-01-09 12:22:37 EST
Also, the option is now "libata.dma" instead of "libata.pata_dma".

Note You need to log in before you can comment on or make changes to this bug.