Bug 247355 - Installer stopped in do_unblank_screen
Summary: Installer stopped in do_unblank_screen
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 7
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-07 18:22 UTC by Patrick Dung
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 17:51:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot message captured by console=ttyS0 (35.58 KB, text/plain)
2007-07-11 17:43 UTC, Patrick Dung
no flags Details

Description Patrick Dung 2007-07-07 18:22:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070509 SeaMonkey/1.1.2

Description of problem:
Hardware: Asus P5E-plus, Core 2, 4GB RAM, SATA II HD, Gefore 7300LE

Actually, I can boot CentOS 5 x64, so I try to boot FC7 x64 rescue CD first.
I use the install option. Below is the trace (it may have typo)

Code: ff 13 83 f8 01 75 03 0b 6b 08 48 8b 5b 28 41 09 c4 48 85 db
RIP  [<ffffffff0820f92f>] handle_IRQ_event+0x23/0x53
 RSP <ffffffff8065df28>
BUG: warning at drivers/char/vt.c:3411/do_unblank_screen() (Not tainted)

Call Trace: 
  <IRQ>  [<ffffffff803882e9>] do_unblank_screen+0x67/0x14a
  [<ffffffff80334b34>] bust_spinlock+0x19/0x29
  [<ffffffff8025e182>] oops_end+0x15/0x57
  [<ffffffff8026462b>] die+0x46/0x50
  [<ffffffff8025e75d>] do_general_protection+0xfe/0x107
  [<ffffffff8025ddfd>] error_exit+0x0/0x84
  [<ffffffff8020f92f>] handle_IRQ_event+0x23/0x53
  [<ffffffff802aebd2>] handle_edge_irq+0xe4/0x128
  [<ffffffff80265498>] do_IRQ+0xf1/0x15f
  [<ffffffff80250e37>] mwait_idle+0x0/0x45
  [<ffffffff80257631>] ret_from_intr+0x0/0xa
  <EOI>  [<ffffffff80259e7a>] mwait_idle+0x42/0x45
  [<ffffffff80244224>] cpu_idle+0x8c/0xaf
  [<ffffffff80609815>] start_kernel+0x2b9/0x2c5
  [<ffffffff8060915c>] _sinittext+0x15c/0x160

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1 . Try to install FC7

Actual Results:


Expected Results:


Additional info:

Comment 1 Patrick Dung 2007-07-07 18:24:09 UTC
Typo in my first post:
Actually, I CANNOT boot CentOS 5 x64, so I try to boot FC7 x64 rescue CD first.

Comment 2 Chuck Ebbert 2007-07-09 22:51:32 UTC
Oops is not in do_unblank screnn, it is before that and has scrolled off the
page. Try booting in 50-line mode (add "vga=ask" to the kernel command line.)
Then take a picture of the screen with a digital camera and post that.


Comment 3 Patrick Dung 2007-07-11 17:43:20 UTC
Created attachment 158979 [details]
boot message captured by console=ttyS0

boot message captured by console=ttyS0

Comment 4 Christopher Brown 2007-09-17 21:10:31 UTC
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. As this appears to be
an installer bug it would be good if you could test the latest version of Fedora
8, available from:

http://fedoraproject.org/wiki/Distribution/Download

so that we can resolve as many of these issues as possible.

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris

Comment 5 Patrick Dung 2007-11-01 17:47:07 UTC
Hello,

I have tried to download a recent fc8 development iso boot image only from
http://ftp.jaist.ac.jp/pub/Linux/Fedora/development/x86_64/os/

kernel version:
2.6.23.1-42.fc8 (kojibuilder@xenbuilder2.fedora.redhat.com) #1 SMP Tue Oct 30
13:18:33 EDT 2007

It did boot normally to installation program, I did not continue the installation.

I think this bug report should be resolved in FC8 release.

Regards
Patrick

Comment 6 Chuck Ebbert 2007-11-01 17:51:43 UTC
You could also try the Fedora 7 respin:

http://spins.fedoraunity.org/spins

In any case, closing as fixed in rawhide, since we can't ever fix the original
install disk.



Note You need to log in before you can comment on or make changes to this bug.