Bug 247372 - OpenOffice.org Window Image Corruption when running under Compiz
Summary: OpenOffice.org Window Image Corruption when running under Compiz
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 7
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL: http://blog.chris.tylers.info/uploads...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-08 05:51 UTC by Chris Tyler
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-08 10:09:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Tyler 2007-07-08 05:51:43 UTC
Description of problem:
- When running under Compiz, small portions of the OpenOffice.org writer window
are often corrupted after switching to another virtual desktop and back again.
See screenshot at http://blog.chris.tylers.info/uploads/compiz-OOo-artifacts.png
for an example.

- The image corruption occurs in the "Apply Style", "Font Name", and "Font Size"
drop-down menus as well as in the three PgUp/PgDn icons in the lower-right
corner. The rest of the window image is unaffected.

Version-Release number of selected component (if applicable):
- compiz-0.3.6-8.fc7
- openoffice.org-core 2.2.0-14.11

How reproducible:
- Start OOo
- Switch around to another virtual desktop and perform some activity
- Switch back

Actual results:
- See screenshot

Expected results:
- No image corruption

Additional info:
- This is a multiseat system, but the problem occurs even in 1-user operation
- This problem does not happen with any other X client
- This problem does not occur when Compiz is disabled and Metacity is used
instead (i.e., "Enable Desktop Effects" is disabled)
- This problem does not affect any other parts of the OOo window
- Video driver is NVIDIA proprietary driver from Livna repository
- I have not been able to correlate the image corruption with any other event,
but it does not occur if you simply switch virtual desktops and switch back
again immediately
- Compiz module configuration: 'cube' and 'wobble' are enabled, 'zoom' is
disabled, everything else set to F7 defaults
- I have not observed this with other OOo apps (Impress, Calc) but I use them
far less often that Writer

Marked as Medium priority only due to the frequency of occurrence.

Comment 1 Caolan McNamara 2007-07-08 10:09:12 UTC
I'm sorry, but I just can't fix anything that revolves around the nvidia driver
:-( Perhaps it's worth bringing it up an qa.openoffice.org upstream.

Comment 2 Chris Tyler 2007-07-08 13:58:36 UTC
I definitely understand! -- but I don't think this is an NVIDIA driver issue.
I'll try to recreate this on another system that uses an open-source driver and
will reopen the bug if it occurs there.


Note You need to log in before you can comment on or make changes to this bug.