Bug 247390 - missing mgraph.h for /usr/include/GL/mglmesa.h
missing mgraph.h for /usr/include/GL/mglmesa.h
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-08 15:53 EDT by John Ellson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 6.5.2-13.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 19:36:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2007-07-08 15:53:31 EDT
Description of problem:
/usr/include/GL/mglmesa.h has an #include <mgraph.h> but there is no mgraph.h
under /usr/include.    So 2 bugs:  missing mgraph.h and missing rpm dependency
on package containing mgraph.h

Version-Release number of selected component (if applicable):
mesa-libGL-devel-6.5.2-10.fc7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. try to build anything that uses /usr/include/GL/mglmesa.h
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Jackson 2007-07-09 11:13:54 EDT
Well, that header file shouldn't ever get installed, since we're not installing
any library that provides that API.

As of mesa 6.5.2-12, mglmesa.h (and many others with the same problem) are no
longer installed.
Comment 2 Fedora Update System 2007-07-11 11:17:35 EDT
mesa-6.5.2-13.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 3 John Ellson 2007-07-12 08:26:39 EDT
Can you push mesa-6.5.2-13 to fedora-development please?
Comment 4 Adam Jackson 2007-07-12 16:17:30 EDT
Trying to.  There's a gcc bug in rawhide that's preventing Mesa from building. 
Once it does though...
Comment 5 Fedora Update System 2007-07-12 19:36:51 EDT
mesa-6.5.2-13.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.