Bug 247421 - [ja_JP] kaffeine: won't start (nonroot)
Summary: [ja_JP] kaffeine: won't start (nonroot)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-09 07:18 UTC by Mamoru TASAKA
Modified: 2008-03-26 09:19 UTC (History)
3 users (show)

Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 01:09:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mamoru TASAKA 2007-07-09 07:18:55 UTC
Description of problem:
* I am using GNOME environment
* My locale is ja_JP.UTF-8 if it is needed

Trying to launch kaffeine from normal user does not
succeed.
Launching kaffeine from root succeeds.

Version-Release number of selected component (if applicable):
kaffeine 0.8.4-1.fc7

How reproducible:
100%

Steps to Reproduce:
1. login to GNOME as normal user
2. launch gnome-terminal
3. type "kaffeine"
  
Actual results:
kaffeine won't start

Expected results:
kaffeine should start

Additional info:
Several Japanese Fedora 7 users complain about this
on Japanese Fedora BBS and I confirmed this.
http://bbs.fedora.jp/read.php?FID=11&TID=6015

Comment 1 Rex Dieter 2007-07-09 11:21:01 UTC
Can you try 2 things:
1.  Does it launch ok in kde?
2.  rpm -q qt kdelibs

Comment 2 Mamoru TASAKA 2007-07-09 11:37:25 UTC
Well,

1. I don't have KDE installed (kdelibs is installed, but kdebase
   is not installed...)
   What is needed? kdebase & kde-i18n-Japanese?
2. qt-3.3.8-4.fc7
   kdelibs-3.5.7-0.1.fc7


Comment 3 Rex Dieter 2007-07-09 11:48:16 UTC
1. yeah, kdebase at least, kde-i18n-Japanese is optional.

Hmm, I'm unable to reproduce,
$ env LANG=ja_JP.UTF-8 KDE_LANG=ja kaffeine
WORKSFORME.

Comment 4 Mamoru TASAKA 2007-07-09 12:13:27 UTC
Well, now I have kdebase, kde-i18n-Japanese installed,
session KDE starts properly.

However even on KDE kaffeine doesn't seem to launch.

Comment 5 Mamoru TASAKA 2007-07-09 12:49:22 UTC
Same on rawhide, on GNOME and KDE.

Comment 6 Mary Ellen Foster 2007-09-07 15:01:40 UTC
It appears that it may be a problem with SCIM rather than with LANG settings
directly ...
http://www.mepislovers.org/forums/showpost.php?s=145b2df534d225d6023b56e5e0b760ac&p=22912&postcount=6

I don't know how to test it, though.

Comment 7 Rex Dieter 2007-09-07 15:19:55 UTC
Let's see if the scim folks have any comment... ? :)

Comment 8 Jens Petersen 2007-09-10 04:20:51 UTC
Reproduced under F7 with XIM.  I suggest installing scim-qtimm if you need scim
support under qt/kde, otherwise it is probably better to uninstall scim.
The qtimm in scim-qtimm provides much better support than using XIM for KDE apps.

(I can't reproduce this with current rawhide FWIW.)


Comment 9 Jens Petersen 2007-09-10 04:23:04 UTC
(I should have mentioned the preceding comment is based on testing
under GNOME btw.)

Comment 10 Jens Petersen 2007-09-10 05:43:47 UTC
I tried to test F7 also with scim-1.4.7-2.fc8 from rawhide and still
kaffeine does not start under XIM, so I suggest this may not a scim bug
since it works ok with scim-1.4.7-2.fc8 under F8 testing.

(I couldn't reproduce the problem with kinput2 fwiw.)

Comment 11 Mamoru TASAKA 2008-01-15 15:23:01 UTC
On rawhide it seems okay. For F-8 I will try on next logout...
I can no longer try F-7...

Comment 12 Caius Chance 2008-03-06 01:09:16 UTC
My fresh installed F8 is able to start. Could we close this bug?


Note You need to log in before you can comment on or make changes to this bug.