Bug 247434 - default lynx background/foreground color
default lynx background/foreground color
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lynx (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 06:26 EDT by Andras Simon
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-17 10:54:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lynx.cfg (140.81 KB, text/plain)
2007-07-10 06:33 EDT, Andras Simon
no flags Details
ynx-site.cfg (66 bytes, text/plain)
2007-07-10 06:35 EDT, Andras Simon
no flags Details
lynx.lss (3.50 KB, text/plain)
2007-07-10 06:35 EDT, Andras Simon
no flags Details
lynx in an xterm (1.47 KB, image/png)
2007-07-16 14:14 EDT, Andras Simon
no flags Details
~/.lynxrc (12.60 KB, application/octet-stream)
2007-07-16 14:36 EDT, Andras Simon
no flags Details

  None (edit)
Description Andras Simon 2007-07-09 06:26:53 EDT
Description of problem:

With the present /etc/lynx.lss, lynx starts with black foreground and background
color in xterm.

Version-Release number of selected component (if applicable):

lynx-2.8.6-3.fc7

How reproducible:

Always

Steps to Reproduce:
1.Start lynx in an xterm.

  
Actual results:

Unreadable pages because of the same background and foreground colors.

Expected results:

Different background and foreground colors.


Additional info:

Starting lynx with
lynx -lss=/dev/null
is a workaround.

Also, colors are fine in a VT.
Comment 1 Ivana Varekova 2007-07-10 05:48:48 EDT
Please could you attach here your configure files (/etc/lynx-site.cfg
/etc/lynx.cfg /etc/lynx.lss). Thanks.
Comment 2 Andras Simon 2007-07-10 06:33:53 EDT
Created attachment 158839 [details]
lynx.cfg
Comment 3 Andras Simon 2007-07-10 06:35:04 EDT
Created attachment 158840 [details]
ynx-site.cfg
Comment 4 Andras Simon 2007-07-10 06:35:57 EDT
Created attachment 158841 [details]
lynx.lss
Comment 5 Ivana Varekova 2007-07-10 08:37:22 EDT
Please could you attach here the output of command:
xrdb -query
Comment 6 Andras Simon 2007-07-10 10:05:56 EDT
(In reply to comment #5)
> Please could you attach here the output of command:
> xrdb -query

Sure!

Xft.dpi:        75
Xft.hinting:    true
Xft.hintstyle:  hintmedium
Comment 7 Ivana Varekova 2007-07-12 08:20:29 EDT
Hello,
could you please try to test whether this problem affects gnome-terminal too.
And please could you attach a snapshot of xterm lynx output here. Thanks.
Comment 8 Ivana Varekova 2007-07-12 08:23:48 EDT
And could you attach here .lynxrc configure file from your home directory?
Comment 9 Andras Simon 2007-07-16 14:14:52 EDT
Created attachment 159349 [details]
lynx in an xterm
Comment 10 Andras Simon 2007-07-16 14:26:31 EDT
(In reply to comment #7)
> could you please try to test whether this problem affects gnome-terminal too.

It does.
Comment 11 Andras Simon 2007-07-16 14:35:41 EDT
(In reply to comment #8)
> And could you attach here .lynxrc configure file from your home directory?

Will do in a moment. But just having

show_color=never

in .lynxrc is enough to reproduce the bug. And conversely, if I comment it out,
the foreground and background colors are different. So this is a temporary
workaround. Thanks!


Comment 12 Andras Simon 2007-07-16 14:36:31 EDT
Created attachment 159353 [details]
~/.lynxrc
Comment 13 Ivana Varekova 2007-07-17 10:54:24 EDT
fixed in lynx-2.8.6-4.fc8

Note You need to log in before you can comment on or make changes to this bug.