Bug 247455 - kdm memory corruption errors due to ICEauthority patch!
kdm memory corruption errors due to ICEauthority patch!
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 243560
  Show dependency treegraph
 
Reported: 2007-07-09 09:27 EDT by Sammy
Modified: 2007-11-30 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version: 3.5.7-9.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-23 11:50:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
unable to login with kdm - log file (53.17 KB, text/plain)
2007-07-17 17:02 EDT, Nadav Kavalerchik
no flags Details

  None (edit)
Description Sammy 2007-07-09 09:27:39 EDT
We have been trying to track down a bug with KDE people that effected
FC6, FC7, etc. and Ubuntu users. The bug is reports in the /var/log/messages
file like:

    kdm_greet[28386]: Internal error: memory corruption detected

See,

    http://bugs.kde.org/show_bug.cgi?id=147454

Well, finally we traced it to the kdelibs-3.5.7-ICEauthority.patch
where the last setenv command resets the HOME environment prematurely
for kdm, which should remain as /tmp/.some-random-numbers. Needless
to say we spent a lot of time tracking this down. What is the purpose
of this patch? Should the 1 in setenv for HOME be 0?
Comment 1 Sammy 2007-07-09 11:49:35 EDT
Also, with this patch /tmp directory fills up with directories /tmp/xxxxx
since kdm cannot clean its tmp directory, which changes to /root. We are
lucky that kdm does not remove /root by accident during cleanup!
Comment 2 Kevin Kofler 2007-07-09 11:50:35 EDT
Looking at what the patch fixes (running KDE apps with sudo corrupting 
permissions in user home directories), I wonder if the KDM log message isn't 
the lesser evil.
Comment 3 Sammy 2007-07-09 12:00:37 EDT
I have spent enough time trying to track this down. The bottom line seems
to be that whatever needs to be done for sudo should be coordinated with
kdm/kde. As I said in comment #1, it would have been easy to delete /root
since kdm has "rm -rf ..." in the cleanup code for kdm and you don't want
this happening suddenly if KDE folks are not aware of this problem/change.

Could one put test to the patch to check if the application is kdm, kdm_greet,
etc. Or someone has to patch kdm to not use HOME environment.
Comment 4 Kevin Kofler 2007-07-09 12:06:43 EDT
So this looks dangerous indeed.
Comment 5 Rex Dieter 2007-07-09 12:16:26 EDT
fwiw, it looks like omitting this patch fixes the XDMCP problems folks have
reported also.
Comment 6 Kevin Kofler 2007-07-09 12:19:11 EDT
Then killing it is probably the right thing to do after all, but we should try 
to work together with upstream and Kubuntu for a non-hack solution to the 
original sudo problem. (I don't think this issue is going to magically go away 
with KDE 4 either.)
Comment 7 Rex Dieter 2007-07-09 12:21:18 EDT
%changelog
* Mon Jul 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 6:3.5.7-9
- omit ICEauthority patch (kde#147454, rh#247455)

devel/rawhide only for now, will likely push an update for FC-6/F-7 soon.
Comment 8 Kevin Kofler 2007-07-12 08:00:21 EDT
Don't forget that we still need Than to push the FC6 update (unless F6 gets 
merged).
Comment 9 Nadav Kavalerchik 2007-07-13 15:39:56 EDT
i use a fc7 system that was dist-upgraded from fc6.
before the upgrade i could connect remotely to the server running kdm
i use an LTSP setup on the server, which means we have terminals connecting to
the server.

i followed the bug report that was filed with kde and this thread too.
i've downloaded the latest kdelibs 6:3.5.7-9 from rawhide and installed it.
indeed the memory corruption is gone but still i can't login :-(

i run kdm with debug level 7, so i can provide the logs if it's helpful.
how can i help to solve this ?

kindly,
nadav :-)
Comment 10 Fedora Update System 2007-07-16 12:50:42 EDT
kdelibs-3.5.7-9.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Rex Dieter 2007-07-17 15:18:31 EDT
Nadav, your problem "can't login" is highly likely a separate issue, please file
a separate bug report, including details of your symptoms.
Comment 12 Nadav Kavalerchik 2007-07-17 17:02:27 EDT
Created attachment 159473 [details]
unable to login with kdm - log file
Comment 13 Nadav Kavalerchik 2007-07-17 17:03:28 EDT
i've just installed the testing packages and i still can't login.

i can't login from remote or with Xnest (inside root session)
although i can Switch User --> Start new session from KDE with no problem.

i'm attaching a kdm log, in case you can point me to what i'm doing wrong
Comment 14 Kevin Kofler 2007-07-17 17:06:01 EDT
> i've just installed the testing packages and i still can't login.

This confirms what Rex Dieter said: Your problem is separate, please file a 
separate bug report.
Comment 15 Nadav Kavalerchik 2007-07-17 18:20:11 EDT
i've started a separate bug report 248653:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=248653
Comment 16 Fedora Update System 2007-07-23 11:49:58 EDT
kdelibs-3.5.7-9.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.