Bug 247496 - Logitec bluetooth keyboard/mouse only work after adaptor is reset
Logitec bluetooth keyboard/mouse only work after adaptor is reset
Status: CLOSED DUPLICATE of bug 157971
Product: Fedora
Classification: Fedora
Component: bluez-libs (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 12:40 EDT by Andrew Cagney
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-21 08:10:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (24.77 KB, text/plain)
2007-07-09 12:40 EDT, Andrew Cagney
no flags Details

  None (edit)
Description Andrew Cagney 2007-07-09 12:40:02 EDT
(perhaps this is a kernel bug?)

Description of problem:

On first boot, the Logictech mouse/keyboard do not work.  Re-plugging the
logitech bluetooth adapter fixes the problem.

Version-Release number of selected component (if applicable):

Linux morgan 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 14:56:37 EDT 2007 x86_64 x86_64
x86_64 GNU/Linux
$ rpm -q bluez-libs
bluez-libs-3.9-1.fc7.x86_64

How reproducible:

appears to be 100%

--

On first boot there's:

usb 1-8.2: configuration #1 chosen from 1 choice
input: Logitech Logitech BT Mini-Receiver as /class/input/input3
input: USB HID v1.11 Keyboard [Logitech Logitech BT Mini-Receiver] on usb-0000:0
0:0b.0-8.2

and then after the re-plug there's also:

usb 1-8: USB disconnect, address 3
usb 1-8.2: USB disconnect, address 4
usb 1-8: new full speed USB device using ohci_hcd and address 9
usb 1-8: configuration #1 chosen from 1 choice
hub 1-8:1.0: USB hub found
hub 1-8:1.0: 3 ports detected
usb 1-8.2: new full speed USB device using ohci_hcd and address 10
usb 1-8.2: configuration #1 chosen from 1 choice
input: Logitech Logitech BT Mini-Receiver as /class/input/input7
input: USB HID v1.11 Keyboard [Logitech Logitech BT Mini-Receiver] on usb-0000:0
0:0b.0-8.2
usb 1-8.3: new full speed USB device using ohci_hcd and address 11
usb 1-8.3: configuration #1 chosen from 1 choice
input: Logitech Logitech BT Mini-Receiver as /class/input/input8
input,hiddev96: USB HID v1.11 Mouse [Logitech Logitech BT Mini-Receiver] on usb-
0000:00:0b.0-8.3
Comment 1 Andrew Cagney 2007-07-09 12:40:02 EDT
Created attachment 158783 [details]
dmesg
Comment 2 David Woodhouse 2007-07-21 08:10:48 EDT
When it's not working, is it in Bluetooth mode instead of HID mode? I suspect
this is a duplicate of bug #157971 -- you just need to make sure hidd is running
and your mouse/keyboard manage to connect after you switch to proper Bluetooth mode.

*** This bug has been marked as a duplicate of 157971 ***

Note You need to log in before you can comment on or make changes to this bug.