Bug 247542 - SELinux prevents ksycoca from building it's database
Summary: SELinux prevents ksycoca from building it's database
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
(Show other bugs)
Version: 7
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-09 20:13 UTC by Jeroen Beerstra
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-09 22:24:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeroen Beerstra 2007-07-09 20:13:08 UTC
Description of problem: SELinux prevents ksycoca from building it's database, I
noticed this because Amarok refused to run after the latest update.

Version-Release number of selected component (if applicable): 

selinux-policy-targeted-2.6.4-25.fc7
kdelibs-3.5.7-0.1.fc7

How reproducible:


Steps to Reproduce:
1. make sure selinux is enabled
2. $ kbuildsycoca
  
Actual results:

$ kbuildsycoca
kbuildsycoca running...
Reusing existing ksycoca
kbuildsycoca: ERROR creating database '/var/tmp/kdecache-jeroen/ksycoca'! File
or directory does not exist
$

Expected results:

$ kbuildsycoca
kbuildsycoca running...
Reusing existing ksycoca
$

Additional info:

type=AVC msg=audit(1184010895.351:1867): avc:  denied  { associate } for 
pid=8771 comm="kbuildsycoca" name="ksycoca7KRaac.new"
scontext=user_u:object_r:unlabeled_t:s0 tcontext=system_u:object_r:fs_t:s0
tclass=filesystem
type=PATH msg=audit(1184010895.351:1867): item=1
name="/var/tmp/kdecache-jeroen/ksycoca7KRaac.new" inode=1867787 dev=fd:05
mode=0100600 ouid=500 ogid=500 rdev=00:00 obj=user_u:object_r:unlabeled_t:s0

Comment 1 Jeroen Beerstra 2007-07-09 22:24:06 UTC
This seems related to seedit (which I installed and then deinstalled), after I
cleaned out /var/tmp, relabed my filesystem and cleaned out all additions it
made to /etc/audit/audit.rules. 

There should be a warning for seedit, this seriously messes with your F7 system!
It promisses to restore your config upon deinstallation but clearly doesn't.


Note You need to log in before you can comment on or make changes to this bug.