Bug 247578 - Wacom tablet pad buttons and wheel don't work
Wacom tablet pad buttons and wheel don't work
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: linuxwacom (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Aristeu Rozanski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 22:43 EDT by Daniel Benamy
Modified: 2008-02-13 15:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 15:06:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Benamy 2007-07-09 22:43:45 EDT
Description of problem:
After enabling the X drivers for the Wacom Graphire tablet using your snippet
from https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169118#c10, the wheel
on the pad stopped working and I noticed that the buttons don't work (I hadn't
tried them before enabling the driver).

Version-Release number of selected component (if applicable):
linuxwacom-0.7.4_1-2.1
xorg-x11-server-Xorg-1.1.1-47.10.fc6
Comment 1 Daniel Benamy 2007-07-10 02:21:00 EDT
I followed the directions from http://gentoo-wiki.com/HOWTO_Wacom_Tablet which say:
 Graphire4 buttons

You will probably need linuxwacom 0.7.4 or higher for this to work with xorg 7.

Add the following line to the "ServerLayout" section of your /etc/X11/xorg.conf
file:

InputDevice    "pad" "SendCoreEvents"

Note: I came across info advising NOT to add "SendCoreEvents" to the line.
However without it the buttons will not work. In combination with the
ButtonsOnly option -see below- the problems described elsewhere will not occur.

Then you will need to add an InputDevice section. Here is what I have in my
/etc/X11/xorg.conf file.


File: xorg.conf

Section "InputDevice"
        Identifier  "pad"
        Driver      "wacom"
        Option      "Type" "pad"
        Option      "Device" "/dev/input/event2"
        Option      "ButtonsOnly" "on"
        Option      "Button9" "2"
        Option      "Button13" "3"
        Option      "USB" "on"
EndSection

The important option is the one with "ButtonsOnly" "on". Without this option as
soon as you activate any button on the pad the pointer will jump to the top left
corner of the screen. Since there is nothing to scroll there the wheel on the
pad will not seem to work. With the ButtonsOnly option the wheel on the pad
should work. To get the other two buttons to do something usefull they need to
be mapped. I got the Button9 and Button13 info by running:

# xidump pad

in a terminal and pressing the buttons on the pad. Do this before you map the
buttons. 

This made the wheel and buttons work.
Comment 2 Aristeu Rozanski 2007-08-21 09:52:52 EDT
Daniel, there's an updated version of linuxwacom on F7 testing updates repository.
Please try only using the configuration I provided in that BZ# and tell me how it
goes.
Comment 3 Aristeu Rozanski 2008-01-07 11:49:09 EST
Daniel, any news on this one?
Comment 4 Aristeu Rozanski 2008-02-13 15:06:22 EST
I'm closing this one. if you still have problems, please feel free to reopen it.

Note You need to log in before you can comment on or make changes to this bug.