Bug 247582 - [LSI-M 5.1 Beta bug] Include intercept cmd timeout and throttle I/O patch
[LSI-M 5.1 Beta bug] Include intercept cmd timeout and throttle I/O patch
Status: CLOSED DUPLICATE of bug 245184
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Chip Coldwell
Martin Jenner
:
Depends On: 225221
Blocks: 217103
  Show dependency treegraph
 
Reported: 2007-07-10 00:31 EDT by Andrius Benokraitis
Modified: 2015-07-14 00:26 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 10:09:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrius Benokraitis 2007-07-10 00:31:24 EDT
+++ This bug was initially created as a clone of Bug #225221 +++

-- Additional comment from andriusb@redhat.com on 2007-07-06 14:14 EST --
Sumant - this should be fixed post Beta. Chip, do we need another bugzilla to
track this change, or maybe not?

-- Additional comment from coldwell@redhat.com on 2007-07-09 10:07 EST --
(In reply to comment #52)
> Sumant - this should be fixed post Beta. Chip, do we need another bugzilla to
> track this change, or maybe not?

I think it would be good to have a new bugzilla to track two issues with megaraid:

1.  Version number is wrong.
2.  Throttle I/O patch.

Chip
Comment 1 Andrius Benokraitis 2007-07-10 00:32:27 EDT
commit 05e9ebbefb379a4da782b21b8427c88ac28a2334
Author: Sumant Patro <sumant.patro@lsi.com>
Date:   Thu May 17 05:47:51 2007 -0700

    [SCSI] megaraid_sas: intercept cmd timeout and throttle io
    
    eh_timed_out call back (megasas_reset_timer) is used to throttle io
    to the adapter when it is called the first time for a scmd.
    The MEGASAS_FW_BUSY flag is set and can_queue reduced to 16.
    The can_queue is restored from completion routine in following
    two conditions : 5 seconds has elapsed and
    the # of outstanding cmds in FW is < 17.
    
    Signed-off-by: Sumant Patro <sumant.patro@lsi.com>
    Signed-off-by: James Bottomley <James.Bottomley@SteelEye.com>
Comment 2 Jay Turner 2007-07-26 10:09:34 EDT

*** This bug has been marked as a duplicate of 245184 ***

Note You need to log in before you can comment on or make changes to this bug.