Bug 247604 - High load and packet drop in xen virtualized instances
High load and packet drop in xen virtualized instances
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Rik van Riel
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-10 06:19 EDT by Stanislav Polasek
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 09:32:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifconfig (1.77 KB, text/plain)
2007-07-10 06:19 EDT, Stanislav Polasek
no flags Details
DomU config (509 bytes, application/octet-stream)
2007-07-10 06:21 EDT, Stanislav Polasek
no flags Details
vmstat 1 and ping at the same time (6.11 KB, text/plain)
2007-07-10 06:25 EDT, Stanislav Polasek
no flags Details

  None (edit)
Description Stanislav Polasek 2007-07-10 06:19:24 EDT
Description of problem:
Running RHEL 4.5 instance on RHEL 5 in paravirtualized mode leads to consistent
high load of ksoftirqd and high loss of packet on the network interfaces (mainly
in DomU, occasionally in Dom0). Running more then one paravirtualized domU
increases the packet loss significantly (from 10 to 30-40%).

The system is currently using the kernel-xen-2.6.18-32.el5, to make the 3rd and
4th sata ports (ICH8) visible. However, the behavior is consistent for all
tested kernel versions.

Tried to disable the onboard Intel 82566DC Gigabit Ethernet Controller, and add
the 3c509 NIC - didn't help.

Using the "normal" kernel-2.6.18-32.el5, system boots and runs just fine.

Version-Release number of selected component (if applicable):

kernel-xen-2.6.18-8.1.3.el5
kernel-xen-2.6.18-8.1.6.el5
kernel-xen-2.6.18-32.el5

How reproducible:
Allways

Additional info:
Motherboard: Intel DG965RY
4GB RAM
Intel(R) Core(TM)2 CPU 6600 @2.40GHz
3x HDT722516DLA380 in sw raid 5

the is seems to be extremely slow:
/dev/sda:
 Timing cached reads:   120 MB in  2.04 seconds =  58.82 MB/sec
 Timing buffered disk reads:   38 MB in  3.07 seconds =  12.39 MB/sec

/dev/sdb:
 Timing cached reads:   104 MB in  2.06 seconds =  50.52 MB/sec
 Timing buffered disk reads:   28 MB in  3.06 seconds =   9.14 MB/sec

/dev/sdc:
 Timing cached reads:   120 MB in  2.01 seconds =  59.71 MB/sec
 Timing buffered disk reads:   26 MB in  3.10 seconds =   8.40 MB/sec


lspci:
00:00.0 Host bridge: Intel Corporation 82P965/G965 Memory Controller Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82G965 Integrated Graphics
Controller (rev 02)
00:03.0 Communication controller: Intel Corporation 82P965/G965 HECI Controller
(rev 02)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1
(rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2
(rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3
(rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4
(rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HB/HR (ICH8/R) LPC Interface
Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801HB (ICH8) 4 port SATA AHCI
Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
02:00.0 IDE interface: Marvell Technology Group Ltd. Unknown device 6101 (rev b1)
06:01.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
06:03.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000
Controller (PHY/Link)
Comment 1 Stanislav Polasek 2007-07-10 06:19:24 EDT
Created attachment 158835 [details]
ifconfig
Comment 2 Stanislav Polasek 2007-07-10 06:21:28 EDT
Created attachment 158836 [details]
DomU config
Comment 3 Stanislav Polasek 2007-07-10 06:25:51 EDT
Created attachment 158837 [details]
vmstat 1 and ping at the same time
Comment 4 Stanislav Polasek 2007-07-10 06:28:03 EDT
Running 32 bit kernels on 64bit hw.
Comment 5 Stanislav Polasek 2007-07-11 05:16:45 EDT
The problem was the wrong combination of the kernel+xen versions. Not a RHEL
problem per se. Plz change to NOTABUG.
Comment 6 Rik van Riel 2007-07-11 09:32:09 EDT
OK

Note You need to log in before you can comment on or make changes to this bug.