Bug 247609 - kmod packages have broken dependencies
kmod packages have broken dependencies
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-10 07:01 EDT by Gerd Hoffmann
Modified: 2008-04-03 02:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 02:58:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerd Hoffmann 2007-07-10 07:01:08 EDT
Description of problem:
rpm automagic dependency scripts create lots of "ksym(foo)" dependendencies for
kmod-* packages.  Nobody provides these dependencies though.

Version-Release number of selected component (if applicable):
redhat-rpm-config-8.0.45-15.fc7
Comment 1 Jon Masters 2007-07-10 07:44:29 EDT
Ah. The kernel package used to provide ABI deps, but davej et al wanted it off
in Fedora - I guess that's caused this breakage (weird nobody filed this bug
before). I can disable the ksym dep generation on F7.

Jon.
Comment 2 Gerd Hoffmann 2007-07-12 11:10:25 EDT
Just disabling is probably the best.  Making the kernel rpm provide all symbols
via ksym() generates an insane big list I guess ...

See also bug 247607 while you are busy updating the package ;)
Comment 3 Jon Masters 2007-08-20 03:10:10 EDT
Ah ok. Yeah.

Jon.
Comment 4 Jon Masters 2008-04-02 18:02:33 EDT
Oops, this one fell on the floor. I'm going to check and update r-r-c shortly.
Comment 5 Jon Masters 2008-04-03 02:58:33 EDT
In F-9 the find-requires script won't call find-requires.ksyms. But we probably
want a better solution that allows for the kernel to have these kABI deps too.

Note You need to log in before you can comment on or make changes to this bug.