Bug 247611 - logwatch has lost its useful e-mail subject
logwatch has lost its useful e-mail subject
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-10 07:11 EDT by Matthew Miller
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 08:24:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2007-07-10 07:11:59 EDT
Formerly, logwatch produced e-mail messages with a subject like:

  Subject: Logwatch for system.bu.edu (Linux)

which is pretty handy. In rawhide, we're instead getting:

 Subject: Cron <root@bigcomputer> run-parts /etc/cron.daily

which is not handy at all (easily overlooked, hard to sort, indistinguishable
from cron error messages....)

This is because "Print = No" was changed to "Print = Yes" in
/usr/share/logwatch/default.conf/logwatch.conf. Could that be put back?

Note that this might affect bug #236618. However, since logwatch has its own
configuration for output address, and since it's important to not loose mail to
root anyway, I think changing the anacrontab mail address and expecting it to
redirect logwatch output is the wrong approach anyway. Having a useful subject
line is important.

Thanks!
Comment 1 Ivana Varekova 2007-07-12 08:05:09 EDT
The option "Print" is removed in the next upstream version there is option
"Output". Upstream chose to set this option to "stdout" so the default output
will have the "cron-like" subject. This resolution has the advantage when you
use logwatch command from a command line. I will discuss this problem with
upstream maintainers - but I prefer to have fedora version equivalent with
upstream, so it depends on their resolution.
Comment 2 Matthew Miller 2007-07-12 09:51:01 EDT
Fair enough.

There's another option, then. Rather than having /etc/cron.daily be a symlink to
the main logwatch script, could we instead make it be a wrapper, like so:

#!/bin/sh
exec /usr/share/logwatch/scripts/logwatch.pl --mailto root


Since that's not an upstream thing anyway, we can do that, right?

It'd be *better* if "--mailto" would work without a parameter (in which case it
would respect the MailTo setting in the config file), but oh well.

My personal preference is still for it to be set to mail by default, because you
can always use --print if you want to run it from the command line.
Comment 3 Matthew Miller 2007-07-12 09:53:04 EDT
Or presumably there's an equivalent "--output mail" in the next version -- maybe
that addresses the "it'd be better" issue noted in my last comment. But the
project web site is giving me 403 errors so I'm not able to check myself.
Comment 4 Mike Tremaine 2007-07-18 16:38:25 EDT
The next upstream release [8.0] will remove the symlink directly logwatch in
cron.daily in favor of a shell script that has the "--output mail" option set
with comments about some of the other options.

Apologies for the state of flux that Fedora got hit with on this.

-Mike 

Note You need to log in before you can comment on or make changes to this bug.