Bug 247695 - FRITZ!WLAN USB Stick not recognized by Networkmanager
FRITZ!WLAN USB Stick not recognized by Networkmanager
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
http://www.avm.de/de/frame/frame.php?...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-10 15:25 EDT by Helge Deller
Modified: 2008-04-10 16:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 16:38:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Helge Deller 2007-07-10 15:25:42 EDT
Description of problem:
I've an AVM Fritz!WLAN USB stick, and this one works without problems when 
configured on the commandline via iwconfig. Nevertheless, Networkmanager 
doesn't recognizes it and thus doesn't show a list of available wireless 
networks to choose from.

Version-Release number of selected component (if applicable):
Fedora 7 final, WLAN driver from webpage above

How reproducible:
- modprobe fwlanusb
- no choices in Networkmanager

Maybe it's a problem because HAL does not recognize the USB stick as 
wireless "net.80211" device ?

Additional info:
This is the output of lsusb:
Bus 004 Device 005: ID 057c:6201 AVM GmbH
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass       255 Vendor Specific Subclass
  bDeviceProtocol       255 Vendor Specific Protocol
  bMaxPacketSize0        64
  idVendor           0x057c AVM GmbH
  idProduct          0x6201
  bcdDevice            1.00
  iManufacturer           3
  iProduct                2
  iSerial                 1 TI98FF9CE04000TNETW
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           32
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0x80
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
Device Qualifier (for other device speed):
  bLength                10
  bDescriptorType         6
  bcdUSB               2.00
  bDeviceClass          224 Wireless
  bDeviceSubClass         1 Radio Frequency
  bDeviceProtocol         1 Bluetooth
  bMaxPacketSize0        64
  bNumConfigurations      0
-------------------------------------------------
Output of hal-device:
0: udi = '/org/freedesktop/Hal/devices/usb_device_ffffffff_ffffffff_noserial'
  usb.vendor = 'AVM GmbH'  (string)
  usb.bus_number = 4  (0x4)  (int)
  usb.linux.device_number = 5  (0x5)  (int)
  info.bus = 'usb'  (string)
  usb.device_subclass = 255  (0xff)  (int)
  usb.is_self_powered = false  (bool)
  info.udi 
= '/org/freedesktop/Hal/devices/usb_device_ffffffff_ffffffff_noserial'  
(string)
  usb.speed = 480  (double)
  linux.subsystem = 'usb'  (string)
  usb.device_class = 255  (0xff)  (int)
  usb.device_protocol = 255  (0xff)  (int)
  usb.version_bcd = 512  (0x200)  (int)
  info.subsystem = 'usb'  (string)
  usb.max_power = 500  (0x1f4)  (int)
  info.product = 'USB Interface'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1d.7/usb4/4-2/4-2:1.0'  
(string)
  usb.device_revision_bcd = 256  (0x100)  (int)
  usb.product_id = 25089  (0x6201)  (int)
  usb.serial = '00040EC9FF89'  (string)
  usb.version = 2  (double)
  usb.speed_bcd = 294912  (0x48000)  (int)
  usb.linux.sysfs_path 
= '/sys/devices/pci0000:00/0000:00:1d.7/usb4/4-2/4-2:1.0'  (string)
  usb.configuration_value = 1  (0x1)  (int)
  usb.vendor_id = 1404  (0x57c)  (int)
  usb.num_ports = 0  (0x0)  (int)
  info.parent 
= '/org/freedesktop/Hal/devices/usb_device_57c_6201_00040EC9FF89'  (string)
  usb.product = 'USB Interface'  (string)
  usb.can_wake_up = false  (bool)
  usb.num_interfaces = 1  (0x1)  (int)
  usb.num_configurations = 1  (0x1)  (int)
  info.linux.driver = 'fwlanusb'  (string)

1: udi = '/org/freedesktop/Hal/devices/usb_device_57c_6201_00040EC9FF89'
  linux.subsystem = 'usb'  (string)
  info.product = 'WLAN USB Device'  (string)
  usb_device.device_revision_bcd = 256  (0x100)  (int)
  usb_device.product = 'WLAN USB Device'  (string)
  usb_device.product_id = 25089  (0x6201)  (int)
  usb_device.speed = 480  (double)
  usb_device.vendor = 'AVM GmbH'  (string)
  usb_device.can_wake_up = false  (bool)
  usb_device.configuration_value = 1  (0x1)  (int)
  usb_device.linux.device_number = 5  (0x5)  (int)
  info.linux.driver = 'usb'  (string)
  usb_device.serial = '00040EC9FF89'  (string)
  usb_device.device_class = 255  (0xff)  (int)
  info.parent = '/org/freedesktop/Hal/devices/usb_device_0_0_0000_00_1d_7'  
(string)
  usb_device.bus_number = 4  (0x4)  (int)
  usb_device.device_protocol = 255  (0xff)  (int)
  usb_device.is_self_powered = false  (bool)
  info.subsystem = 'usb_device'  (string)
  info.vendor = 'AVM GmbH'  (string)
  usb_device.version = 2  (double)
  usb_device.num_interfaces = 1  (0x1)  (int)
  usb_device.vendor_id = 1404  (0x57c)  (int)
  usb_device.speed_bcd = 294912  (0x48000)  (int)
  usb_device.version_bcd = 512  (0x200)  (int)
  info.udi = '/org/freedesktop/Hal/devices/usb_device_57c_6201_00040EC9FF89'  
(string)
  usb_device.linux.sysfs_path 
= '/sys/devices/pci0000:00/0000:00:1d.7/usb4/4-2'  (string)
  usb_device.num_configurations = 1  (0x1)  (int)
  info.bus = 'usb_device'  (string)
  linux.device_file = '/dev/4-2'  (string)
  usb_device.num_ports = 0  (0x0)  (int)
  usb_device.max_power = 500  (0x1f4)  (int)
  linux.hotplug_type = 2  (0x2)  (int)
  usb_device.device_subclass = 255  (0xff)  (int)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1d.7/usb4/4-2'  (string)
Comment 1 Dan Williams 2007-10-31 20:56:06 EDT
What driver is this device using?  If it's not recognized as a network device by
HAL, it won't be seen by NM , and that's usually a driver problem.  Please paste
in the output of:

tree /sys/class/net

when the stick is plugged in.  Also, can you give the kernel version you're using?
Comment 2 Helge Deller 2007-11-19 12:45:27 EST
As mentioned above, the driver name is "fwlanusb.ko".
I'd love to give you the output of the /sys/class/net tree, but sadly the 
module doesn't build any longer on Fedora7 with later kernels.
Comment 3 Dan Williams 2008-04-10 16:38:37 EDT
If the driver isn't in the upstream kernel, it can't really be supported by
NetworkManager, usually because non-upstream drivers suck at implementing
wireless extensions...  In this case the fault is likely with the driver itself
not calling the right bits to put itself in sysfs.

Note You need to log in before you can comment on or make changes to this bug.