Bug 247731 - XML validation errors when using DRAC fencing with Blades
XML validation errors when using DRAC fencing with Blades
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
:
Depends On: 229662
Blocks: 248072
  Show dependency treegraph
 
Reported: 2007-07-11 00:21 EDT by Jim Parsons
Modified: 2009-04-16 18:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0639
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:45:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Parsons 2007-07-11 00:21:43 EDT
+++ This bug was initially created as a clone of Bug #229662 +++

Description of problem:


Version-Release number of selected component (if applicable):
Running RHEL4U4 x86 with all errata applied.
System-config-cluster is version 1.0.27-1.0

After setting up cluster.conf to use DRAC fencing with a Dell Blade system the
system-config-cluster tool gives an XML validation error.



tmp/cluster.conf:8: element device: Relax-NG validity error : Invalid attribute
modulename for element device
Relax-NG validity error : Extra element fence in interleave
/tmp/cluster.conf:4: element clusternodes: Relax-NG validity error : Element
clusternode failed to validate content
/tmp/cluster.conf:5: element clusternode: Relax-NG validity error : Element
clusternodes has extra content: clusternode
/tmp/cluster.conf:6: element fence: Relax-NG validity error : Element
clusternode has extra content: fence
/tmp/cluster.conf:2: element cluster: Relax-NG validity error : Invalid sequence
in interleave
/tmp/cluster.conf:2: element cluster: Relax-NG validity error : Element cluster
failed to validate content
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf fails to validate



How reproducible:
100%tmp/cluster.conf:8: element device: Relax-NG validity error : Invalid
attribute modulename for element device
Relax-NG validity error : Extra element fence in interleave
/tmp/cluster.conf:4: element clusternodes: Relax-NG validity error : Element
clusternode failed to validate content
/tmp/cluster.conf:5: element clusternode: Relax-NG validity error : Element
clusternodes has extra content: clusternode
/tmp/cluster.conf:6: element fence: Relax-NG validity error : Element
clusternode has extra content: fence
/tmp/cluster.conf:2: element cluster: Relax-NG validity error : Invalid sequence
in interleave
/tmp/cluster.conf:2: element cluster: Relax-NG validity error : Element cluster
failed to validate content
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf fails to validate



Steps to Reproduce:
This error occurs if you use the modulename option with DRAC fencing to specify
the module within a blade chassis.
See attached sample cluster.conf- created in system-config-cluster


The fix seems to be adding a modulename section to the FENCE schema.
Tested ok with my customer's configuration file.

 <group> 
  <attribute name="modulename"/>
 </group>

-- Additional comment from acathrow@redhat.com on 2007-02-22 11:30 EST --
Created an attachment (id=148589)
Sample cluster.conf created by s-config-cluster


-- Additional comment from wmealing@redhat.com on 2007-07-11 00:02 EST --
Created an attachment (id=158922)
Patch to allow modulename as a parameter in xml for drac interfaces.

Apparently fixed as mentioned in:
http://post-office.corp.redhat.com/archives/cluster-list/2007-February/msg00215.html


But this does not work. This may also be valid for RHEL5 clusters also.
Comment 1 Jim Parsons 2007-07-11 00:25:25 EDT
Can I please respin the system-config-cluster 5.1 beta for this fix? This is
VERY low risk, but fixes a pesky nit in the schema checking.

This is the addition I wish to add...
        <!-- DRAC -->
        <group>
         <optional>
          <attribute name="action"/>
         </optional>
+        <optional>
+         <attribute name="modulename"/>
+        </optional>
        </group>
Comment 2 RHEL Product and Program Management 2007-07-11 00:33:47 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Wade Mealing 2007-07-12 19:22:38 EDT
Original product version was set to 4, flags set to 5.  Modified product version
above, and cloning for version 4.
Comment 4 Jim Parsons 2007-07-17 01:44:08 EDT
This is all set and checked in. This will make it in 5.1 and also will be in the
next rhel4 CS release.
Comment 7 errata-xmlrpc 2007-11-07 11:45:01 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0639.html

Note You need to log in before you can comment on or make changes to this bug.