Bug 247734 - Hald does not free memory when unplug/replugging a usb device.
Hald does not free memory when unplug/replugging a usb device.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: hal (Show other bugs)
4.5
All Linux
high Severity high
: ---
: ---
Assigned To: David Zeuthen
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 01:20 EDT by Wade Mealing
Modified: 2013-03-05 22:51 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-0801
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:06:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing the problem. Tested and confirmed by customer. (2.26 KB, patch)
2007-07-23 07:12 EDT, Jose Plans
no flags Details | Diff

  None (edit)
Description Wade Mealing 2007-07-11 01:20:24 EDT
Description of problem:

When unplugging and replugging a USB device the size of the process hald grows
as the xml data is not free'd.

Version-Release number of selected component (if applicable):

rhel-i386-as-4
hal-0.4.2-6.EL4-i386

How reproducible:

Every time.

Steps to Reproduce:
1. Plug usb disk into machine
2. Unplug usb disk from machine
3. Plug usb disk into machine
  
Actual results:

Hald process space grows in size.

Expected results:

Hald to not grow in size.

Additional info:

There seems to be a bug in processing fdi files that has been fixed upstream,
customer has applied said patch and told that it has been fixed.  

For more information check out IT 124713.

http://webcvs.freedesktop.org/hal/hal/hald/device_info.c?r1=1.16.2.1&r2=1.16.2.2&pathrev=hal-0_4-stable-branch
Comment 2 RHEL Product and Program Management 2007-07-23 06:54:51 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Jose Plans 2007-07-23 07:12:43 EDT
Created attachment 159774 [details]
Patch fixing the problem. Tested and confirmed by customer.
Comment 15 errata-xmlrpc 2007-11-15 11:06:56 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0801.html

Note You need to log in before you can comment on or make changes to this bug.