Bug 247773 - berry_charge kernel module - multiple Blackberry charging issues.
berry_charge kernel module - multiple Blackberry charging issues.
Status: CLOSED DUPLICATE of bug 244790
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 08:02 EDT by Chris Stankaitis
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 10:45:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Stankaitis 2007-07-11 08:02:41 EDT
Description of problem:

The berry_charge module for the .21 kernel is suppose to allow blackberry
charging via USB out of the box.  When I plug in my 7130e the kernel module
loads and it begins charging however a few things happen on a regular basis.

1) The USB device seems to suspend, I have fixed that by adding the
usbcore.autosuspend=0 variable to my kernel line in grub, this should be fixed
in the next fedora kernel from what I read

2) the device frequently disappears when I do an lsusb I get the following
message in my logs which I think may be related.

Jul  9 10:53:39 andromeda udevd[426]: get_netlink_msg: unable to receive kernel
netlink message: No buffer space available

3) when I do get the thing detected and charging, the max power setting is only
100mA as opposed to 500mA which you get when plugged into either a windows box
or the wall jack, thus charging is very slow to non-existant.

Bus 002 Device 022: ID 0fca:0001 Research In Motion, Ltd. Blackberry Handheld
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass       255 Vendor Specific Subclass
  bDeviceProtocol       255 Vendor Specific Protocol
  bMaxPacketSize0        64
  idVendor           0x0fca Research In Motion, Ltd.
  idProduct          0x0001 Blackberry Handheld
  bcdDevice            1.04
  iManufacturer           1 Research In Motion
  iProduct                2 BlackBerry Device
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           46
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0x80
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           4
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x85  EP 5 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval              10
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x05  EP 5 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval              10
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval              10
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x03  EP 3 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval              10





Version-Release number of selected component (if applicable):


How reproducible:

Always

Expected results:

blackberry should charge under Fedora in the same time frame as it does under
other OS' it should stay connected while tethered to the computer.


Additional info:

# uname -a
Linux andromeda.dw 2.6.21-1.3228.fc7 #1 SMP Tue Jun 12 15:37:31 EDT 2007 i686
i686 i386 GNU/Linux
Comment 1 Christopher Brown 2007-09-18 10:45:11 EDT

*** This bug has been marked as a duplicate of 244790 ***

Note You need to log in before you can comment on or make changes to this bug.