Bug 247779 - [RHEL5.2] Evolution message filters on imap folders only work sometimes
Summary: [RHEL5.2] Evolution message filters on imap folders only work sometimes
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-data-server   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Matthew Barnes
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
: 473052 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-11 12:50 UTC by Andreas Haupt
Modified: 2009-09-02 09:14 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 09:14:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1259 normal SHIPPED_LIVE evolution-data-server bug fix update 2009-09-01 09:12:26 UTC

Description Andreas Haupt 2007-07-11 12:50:08 UTC
Description of problem:

When (automatically) filtering messages on imap folders (e.g. moving them to
local folders or assigning colours) this only works partly. The order of the
filters is irrelevant. All messages and their filters are affected from time to
time. It just stops working temporarly for new messages and later it works
again. Selecting the messages and apply the filters manually (Ctrl+y) will
filter the mails correctly everytime which have failed at the automatic filtering.

Version-Release number of selected component (if applicable):

evolution-2.8.0-33.0.1.el5

How reproducible:

Actual results:

It's not really reproducible. Say 30% to 40% of the newly arrived messages won't
be filtered automatically. I cannot see any correlation between correctly
automatically filtered messages and message the automatic filter failed on.

Expected results:

All new messages should be filtered correctly.

Additional info:

I could not find a real equivalent at Gnome's bugzilla. This one is the most
similar one: http://bugzilla.gnome.org/show_bug.cgi?id=306107

Comment 1 Matthew Barnes 2008-03-16 22:32:20 UTC
RHEL 5.2 will re-base Evolution from version 2.8.0 to version 2.12.3.
Can you please test whether this bug is still present in RHEL 5.2?

Comment 2 Andreas Haupt 2008-03-31 08:32:13 UTC
Just tested it with evolution 2.12.3 in Fedora8. The bug is still present there.

Comment 3 Matthew Barnes 2008-03-31 10:53:45 UTC
Okay, thanks for the update.

Comment 5 RHEL Product and Program Management 2008-07-21 23:10:38 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 8 Michael Solberg 2009-01-29 22:29:37 UTC
A patch which fixes this issue is in BZ 473052.

Michael.

Comment 9 Milan Crha 2009-03-09 11:34:27 UTC
*** Bug 473052 has been marked as a duplicate of this bug. ***

Comment 11 Cao, Chen 2009-03-13 05:21:14 UTC
message filter does not work on RHEL5.3 i386 Client, too

testing on both MS exchange and imap(gmail).

----------
[xxx]$ rpm -qa |grep evolution

evolution-data-server-doc-1.12.3-10.el5_3.3
evolution-data-server-1.12.3-10.el5_3.3
evolution-2.12.3-8.el5_2.3
evolution-connector-2.12.3-4.el5_2.1
evolution-data-server-debuginfo-1.12.3-10.el5_3.3
evolution-webcal-2.7.1-6
evolution-data-server-devel-1.12.3-10.el5_3.3
----------

Comment 20 errata-xmlrpc 2009-09-02 09:14:13 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1259.html


Note You need to log in before you can comment on or make changes to this bug.