Bug 247786 - vsftpd creates files with incorrect permissions
vsftpd creates files with incorrect permissions
Status: CLOSED DUPLICATE of bug 244686
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: vsftpd (Show other bugs)
3.9
All Linux
low Severity high
: ---
: ---
Assigned To: Maros Barabas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 09:30 EDT by Chris Langlands
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 04:03:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Langlands 2007-07-11 09:30:48 EDT
Since Update 9, users who upload files via vsftpd service have been reporting
unusal permissions-based problems.  Situation has been going on since U9, but
all affected users happened to be using the same FTP client (Transmit on Mac) so
I had put it down to that.  It wasn't until today that I tested the situation
myself using lftp, and I can confirm unusual permissions behaviour with the U9
release of vsftpd.

Version-Release number of selected component:

  vsftpd-1.2.1-3E.12

Not affected:

  vsftpd-1.2.1-3E.6

Steps to reproduce:

1. I take a file with 644 permissions.

  -rw-r--r--  1 cpaul users  3380 Jul 12  2006 TEXTFILE

2. Upload it

  lftp cpaul@fastmedia.com:/> put TEXTFILE
  
3. Check the remote listing

  lftp cpaul@fastmedia.com:/> ls -la
  ----rw-r-x    1 501 501  3380 Jul 11 06:27 TEXTFILE

4. Downgrade vsftpd to vsftpd-1.2.1-3E.6 and repeat

  lftp cpaul@fastmedia.com:/> put TEXTFILE
  lftp cpaul@fastmedia.com:/> ls -la
  -rw-r--r--    1 501 501  3380 Jul 11 06:28 REFACTOR


Possibility that the problem was introduced during this fix?
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=214987

The problem was also mentioned on taroon list here:
http://www.redhat.com/archives/taroon-list/2007-June/msg00032.html

The only local config in my vsftpd.conf is listed below:

  anonymous_enable=NO
  local_umask=022
  chroot_local_user=YES
Comment 1 Maros Barabas 2007-07-12 04:03:06 EDT

*** This bug has been marked as a duplicate of 244686 ***

Note You need to log in before you can comment on or make changes to this bug.