Bug 247810 - qalculate-gtk 0.9.5 will not run with upgraded libqalculate 0.9.6
qalculate-gtk 0.9.5 will not run with upgraded libqalculate 0.9.6
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libqalculate (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 11:16 EDT by Mark Knoop
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-11 11:35:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Knoop 2007-07-11 11:16:46 EDT
Description of problem:
libqalculate-0.9.6-1.fc7 is available and was updated by "yum update" without
requiring that qalculate-gtk 0.9.6 is available. qalculate-gtk dies with a
segmentation fault if run after updating libqalculate. Installing the built, but
not yet pushed qalculate-gtk-0.9.6-1.fc7.i386.rpm from koji solves the problem.
It seems there is a missing Requires in one of these packages.

Version-Release number of selected component (if applicable):
libqalculate-0.9.6-1.fc7
qalculate-gtk-0.9.5-1.fc7

How reproducible:
100%

Steps to Reproduce:
1. have qalculate-gtk, libqalculate 0.9.5 installed
2. yum update
3. try to run qalculate-gtk
  
Actual results:
Segmentation Fault
Comment 1 Deji Akingunola 2007-07-11 11:24:01 EDT
qalculate-gtk-0.9.6 is currently in updates-testing, it should be pushed to
stable updates repo soon-ish.
Comment 2 Mark Knoop 2007-07-11 11:31:05 EDT
OK, but surely rpm/yum should not upgrade libqalculate before qalculate-gtk is
available. Perhaps "Conflicts: qalculate-gtk < 0.9.6" is needed?
Comment 3 Deji Akingunola 2007-07-11 11:35:41 EDT
(In reply to comment #2)
> OK, but surely rpm/yum should not upgrade libqalculate before qalculate-gtk is
> available. Perhaps "Conflicts: qalculate-gtk < 0.9.6" is needed?
Noted, will address this in a future update. Thanks

Note You need to log in before you can comment on or make changes to this bug.