Bug 247831 - Update to gnome-sharp breaks upgrade path
Summary: Update to gnome-sharp breaks upgrade path
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-sharp (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
urgent
high
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 247939 248009 248531 (view as bug list)
Depends On:
Blocks: 248107
TreeView+ depends on / blocked
 
Reported: 2007-07-11 16:06 UTC by Alex Lancaster
Modified: 2007-11-30 22:12 UTC (History)
18 users (show)

Fixed In Version: 2.16.0-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 20:55:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff between the files contained in the installed and new version of gnome-sharp (4.85 KB, text/plain)
2007-07-12 08:50 UTC, Nils Philippsen
no flags Details
updated SRPM (478.77 KB, application/x-rpm)
2007-07-17 10:00 UTC, Gen Zhang
no flags Details

Description Alex Lancaster 2007-07-11 16:06:44 UTC
Description of problem:
Update to gnome-sharp breaks upgrade path


Version-Release number of selected component (if applicable):
gnome-sharp-2.16.0-2.fc7

How reproducible:
Always

Steps to Reproduce:
1. yum upgrade
  
Actual results:
Resolving Dependencies
--> Running transaction check
---> Package liferea.i386 0:1.2.19-2.fc7 set to be updated
---> Package libjpeg-devel.i386 0:6b-38.fc7 set to be updated
---> Package libjpeg.i386 0:6b-38.fc7 set to be updated
---> Package gnome-screensaver.i386 0:2.18.2-2.fc7 set to be updated
---> Package opensp.i386 0:1.5.2-5.fc7 set to be updated
---> Package docbook-simple.noarch 0:1.1-1.02.fc7 set to be updated
---> Package docbook-utils-pdf.noarch 0:0.6.14-8.fc7 set to be updated
---> Package cpuspeed.i386 1:1.2.1-2.fc7 set to be updated
---> Package cvs.i386 0:1.11.22-9.1.fc7 set to be updated
---> Package vim-enhanced.i386 2:7.1.12-1.fc7 set to be updated
---> Package docbook-utils.noarch 0:0.6.14-8.fc7 set to be updated
---> Package gnome-sharp.i386 0:2.16.0-2.fc7 set to be updated
---> Package vim-minimal.i386 2:7.1.12-1.fc7 set to be updated
---> Package smolt.noarch 0:0.9.8.3-1.fc7 set to be updated
---> Package glibc.i686 0:2.6-4 set to be updated
---> Package glibc-devel.i386 0:2.6-4 set to be updated
---> Package vim-X11.i386 2:7.1.12-1.fc7 set to be updated
---> Package hpijs.i386 1:1.7.4a-4.fc7 set to be updated
---> Package policycoreutils.i386 0:2.0.16-10.fc7 set to be updated
---> Package glibc-common.i386 0:2.6-4 set to be updated
---> Package vim-common.i386 2:7.1.12-1.fc7 set to be updated
---> Package libsane-hpaio.i386 0:1.7.4a-4.fc7 set to be updated
---> Package glibc-utils.i386 0:2.6-4 set to be updated
---> Package smolt-gui.noarch 0:0.9.8.3-1.fc7 set to be updated
---> Package nscd.i386 0:2.6-4 set to be updated
---> Package ltrace.i386 0:0.5-7.45svn.fc7 set to be updated
---> Package glibc-headers.i386 0:2.6-4 set to be updated
--> Processing Dependency: mono(gtkhtml-sharp) = 2.16.0.0 for package: f-spot
--> Finished Dependency Resolution
Error: Unresolveable requirement mono(gtkhtml-sharp) = 2.16.0.0 for f-spot


Expected results:
Upgrade to proceed.

Additional info:

Comment 2 Nils Philippsen 2007-07-12 08:50:24 UTC
Created attachment 159039 [details]
diff between the files contained in the installed and new version of gnome-sharp

Comment 3 Julian Sikorski 2007-07-12 10:26:24 UTC
*** Bug 247939 has been marked as a duplicate of this bug. ***

Comment 4 David Juran 2007-07-12 10:35:14 UTC
Changing the BuildRequires from gtkhtml3-devel to gtkhtml38-devel ought to do
the trick.

Comment 5 Hansen Tanjung 2007-07-13 06:27:31 UTC
The gnome-sharp-2.16.0-2.fc7 missing provide mono(gtkhtml-sharp) that
gnome-sharp-2.16.0-1.fc6 have. The fc6 version I think used by F7 before have an
update.

Comment 6 Alex Lancaster 2007-07-14 03:54:10 UTC
Is the maintainer actively working on fixing this?  This means that f-spot (a
fairly major end-user app) has been uninstallable and systems that have f-spot
currently installed won't update properly for over 2 days now.

Comment 7 Mikkel Kruse Johnsen 2007-07-14 10:04:46 UTC
I can verify that compiling gnome-sharp with gtkhtml38 and gtkhtml38-devel
installed will do the trick. Someone please fix this.

Small request, update monodevelop to 0.14, please.

Comment 8 Brian Pepple 2007-07-14 14:01:05 UTC
*** Bug 248009 has been marked as a duplicate of this bug. ***

Comment 9 Alex Lancaster 2007-07-15 01:22:35 UTC
Bumping up priority to urgent.  This really looks bad for Fedora that a major
app   like f-spot is uninstallable.

Comment 10 Julian Sikorski 2007-07-16 11:17:02 UTC
CCing the comaintainer.

Comment 11 Ignacio Vazquez-Abrams 2007-07-17 09:46:54 UTC
*** Bug 248531 has been marked as a duplicate of this bug. ***

Comment 12 Gen Zhang 2007-07-17 10:00:55 UTC
Created attachment 159412 [details]
updated SRPM

I've attached an updated SRPM. I think I've modified things correctly --
updated changelog, version number, etc. Should I upload my i386 build as well?
I don't really know the correct etiquette on this.

Comment 13 Xavier Lamien 2007-07-17 13:21:55 UTC
I will check your srpm and update that in CVS

Comment 14 Nerijus Baliūnas 2007-07-17 14:58:06 UTC
Is really an additional dependency on gtkhtml38 needed? As told in bug #248009:

It seems that gnome-sharp didn't include the libgtkhtml-sharp libs because
during build it searches for libgtkhtml-3.8.pc package to see if it will build
the libgtkhtml-sharp libs but gtkhtml3-devel package provides libgtkhtml-3.14.pc .

After I created a symbolic link libgtkhtml-3.8.pc pointing to libgtkhtml-3.14.pc
in the /usr/lib/pkgconfig directory and then did a gnome-sharp rebuilt and
installed it, now f-sport works fine!

As currently f-spot works with gtkhtml3-3.14.3-1.fc7 and w/o gtkhtml38
installed, I think instead of adding build requirement for gtkhtml38-devel the
source should be fixed to search for libgtkhtml-3.14.pc instead of
libgtkhtml-3.8.pc.

Comment 15 Xavier Lamien 2007-07-17 15:23:04 UTC
hm...that's a good point
i'll do some workaround on the source.

Comment 16 Xavier Lamien 2007-07-17 16:02:47 UTC
Nerijus can you upload somewhere your build log of gnome-sharp.


Comment 17 Nerijus Baliūnas 2007-07-17 16:25:34 UTC
I haven't built it, but I see in configure.in:
GTKHTML_REQUIRED_VERSION=3.8.0
...
GTKHTML_VERSION=3.8
GTKHTML_SOVERSION=15

As gtkhtml38 has libgtkhtml-3.8.so.15, and gtkhtml3-3.14.1-1.fc7 has
libgtkhtml-3.14.so.19, I think the following patch should work:

--- configure.in.orig	2006-08-21 19:46:13.000000000 +0300
+++ configure.in	2007-07-17 19:24:34.000000000 +0300
@@ -195,6 +195,12 @@
 PKG_CHECK_MODULES(RSVG_DEPENDENCIES, librsvg-2.0 >= $RSVG_REQUIRED_VERSION,
enable_rsvg=yes, enable_rsvg=no)
 
 if test "x$enable_gnome" = "xyes"; then
+GTKHTML_REQUIRED_VERSION=3.14.0
+PKG_CHECK_MODULES(GTKHTML_DEPENDENCIES, libgtkhtml-3.14 >=
$GTKHTML_REQUIRED_VERSION, enable_gtkhtml=yes, enable_gtkhtml=no)
+if test "x$enable_gtkhtml" = "xyes"; then
+GTKHTML_VERSION=3.14
+GTKHTML_SOVERSION=19
+else
 GTKHTML_REQUIRED_VERSION=3.8.0
 PKG_CHECK_MODULES(GTKHTML_DEPENDENCIES, libgtkhtml-3.8 >=
$GTKHTML_REQUIRED_VERSION, enable_gtkhtml=yes, enable_gtkhtml=no)
 if test "x$enable_gtkhtml" = "xyes"; then
@@ -225,6 +231,7 @@
 fi
 fi
 fi
+fi
 AC_SUBST(GTKHTML_VERSION)
 AC_SUBST(GTKHTML_SOVERSION)
 else


Comment 18 Nerijus Baliūnas 2007-07-17 17:47:53 UTC
I tested build with this patch, it works. If we name the preceding patch
gnome-sharp-2.16.0-gtkhtml3-3.14.patch, the following patch should be applied to
gnome-sharp.spec:

--- gnome-sharp.spec.orig	2007-07-10 17:38:56.000000000 +0300
+++ gnome-sharp.spec	2007-07-17 20:45:21.000000000 +0300
@@ -11,6 +11,7 @@
 
 Patch1: gnome-sharp-2.15.0-libdir.patch
 Patch2:	%{name}-2.16.0-automake-1.10.patch
+Patch3:	%{name}-2.16.0-gtkhtml3-3.14.patch
 
 BuildRequires:  mono-devel gtk2-devel libart_lgpl-devel gnome-vfs2-devel
libgnomecanvas-devel libgnomeui-devel
 BuildRequires:  gtk-sharp2-devel >= 2.10.0
@@ -43,6 +44,7 @@
 %setup -n gnome-sharp-%{version}
 %patch1 -p1 -b .libdir
 %patch2 -p1 -b .automake-1.10
+%patch3 -p0 -b .gtkhtml3-3.14
 
 %build
 autoreconf --force --install


Comment 19 Luis Villa 2007-07-17 18:33:13 UTC
(Note that I think that the owner of the bug is at GUADEC, hence his lack of
response.)

Comment 20 Xavier Lamien 2007-07-17 18:55:11 UTC
[comment #17]
that was a tested too.

does it also resloved the 'Unresolveable requirement' from yum ?


Comment 21 Nerijus Baliūnas 2007-07-17 19:09:58 UTC
Yes, as f-spot requires mono(gtkhtml-sharp) = 2.16.0.0, and newly built rpm
provides it (I've just checked it).

Comment 22 Xavier Lamien 2007-07-17 19:52:07 UTC
okay,
test pass for me too.
i'll update 

Comment 23 Xavier Lamien 2007-07-18 00:40:05 UTC
released package has been built.

Nerijus, could you test them before i close this bug ?

Comment 24 Alex Lancaster 2007-07-18 01:08:48 UTC
(In reply to comment #23)
> released package has been built.

When you release this bodhi, could you e-mail rel-eng@fedoraproject.org and ask
them to expedite the push of this package to stable ASAP? since it's been broken
for almost a week now.  Thanks.

Comment 25 Fedora Update System 2007-07-18 20:55:39 UTC
gnome-sharp-2.16.0-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 26 gareth foster 2007-07-18 22:00:56 UTC
[root@Woden earthwormgaz]# yum install f-spot
Loading "installonlyn" plugin
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package f-spot.i386 0:0.3.5-2.fc7 set to be updated
--> Processing Dependency: mono(gtkhtml-sharp) = 2.16.0.0 for package: f-spot
--> Finished Dependency Resolution
Error: Missing Dependency: mono(gtkhtml-sharp) = 2.16.0.0 is needed by package
f-spot
[root@Woden earthwormgaz]# date
Wed Jul 18 23:00:42 BST 2007


Comment 27 Julian Sikorski 2007-07-18 22:10:48 UTC
Either f-spot needs a rebuild to pick up the new version, or more likely, the
fix needs to propagate to mirrors.

Comment 28 Xavier Lamien 2007-07-19 00:23:47 UTC
[in reply to comment #26]

hm...i've just make a retry on "yum install f-spot", and it's work fine.
Gareth, will you retry an yum install please.

Comment 29 gareth foster 2007-07-19 09:48:03 UTC
Will do when I get home mate, cheers.


Note You need to log in before you can comment on or make changes to this bug.