Bug 24785 - Compaq SmartArray and LC2 failure in install
Compaq SmartArray and LC2 failure in install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-23 19:11 EST by David Lawrence
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 17:07:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2001-01-23 19:11:43 EST
When using the Compaq SmartArry 5300 and LC2 raid controllers, the install
fails to find any devices to install too despite the kernel messages
detecting a raid device and system drive to install to as reported by VT4.
Comment 1 Glen Foster 2001-01-24 19:38:38 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 2 Glen Foster 2001-01-24 19:48:18 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 3 Michael K. Johnson 2001-02-23 15:39:39 EST
Does the driver work if you select it manually from the expert
install?  I want to make sure that it's only an anaconda bug
and not also a kernel bug...  :-)
Comment 4 David Lawrence 2001-02-27 23:11:07 EST
I was able to get the LC2 controller to work with the latest qa build (0227). It
properly detects the
LC2 and loads the cpqarray module. As for the 5300, it seems to detect the card
properly and
attempts to load the cciss module. After loading the installer loads second
stage but there are
not devices detected to install to. When flipping over to VT4 It shows that the
module detected no
devices. Is this the proper module for this card? I have two of these and they
both do the same thing.
Comment 5 Michael Fulbright 2001-02-28 10:21:07 EST
Still seems to be a kernel module related issue.
Comment 6 David Lawrence 2001-02-28 11:26:58 EST
I do agree if that is in fact the correct module for that card. By looking at
the kernel output which is very minimal for that module it just simply states no
devices found.
Comment 7 Michael K. Johnson 2001-03-01 00:12:35 EST
Please retest with the latest qa tree, this should be fixed.

If the card is installed in a Compaq SMP machine, you may find
that the "noapic" boot option is required to boot the SMP kernel.
If so, please report it here.  Also, please try changing the OS
selection in the BIOS and report that here as well.

Also, if "noapic" is required, please let's put the card in a
non-Compaq machine and see if noapic is required there -- that
may also help determine if the problem is in the Compaq BIOS or
in the driver.
Comment 8 David Lawrence 2001-03-01 11:43:32 EST
I am using one of two 5300 Controllers that I am simply plugging into one of the
woody test 
motherboards in the lab so this is not a compaq smp machine. I will try it again
using the latest build.
Comment 9 David Lawrence 2001-03-08 12:06:02 EST
As of qa0308.0 tree this is now working fine on the AMD Duron woody machine in
the test lab. I was able to use the Compaq Configuration utility to create a
simple RAID1 setup. I then ran the install using 'expert' mode and the cciss
module was loaded automatically detecting the controller and the uninitialized
raid device. The install proceeded normally and everying thing worked fine upon
reboot. One comment is that the disk speed is impressive.

Note You need to log in before you can comment on or make changes to this bug.