Bug 247868 - oidentd masquarade doesn't work under newest kernels (again)
Summary: oidentd masquarade doesn't work under newest kernels (again)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: oidentd   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-11 19:50 UTC by Vilius Šumskas
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 2.0.8-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 16:02:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for oidentd under kernel 2.6.21 and up (1.33 KB, patch)
2007-07-11 19:50 UTC, Vilius Šumskas
no flags Details | Diff

Description Vilius Šumskas 2007-07-11 19:50:31 UTC
Description of problem:
oidentd masquarade functionality is broken again under newest kernels

Version-Release number of selected component (if applicable):
oidentd-2.0.8-2

How reproducible:
Always

Steps to Reproduce:
1. run oidentd with -M flag
  
Additional info:
This is because conntrack NAT was introduced in kernel version 2.6.21. FC6 is 
not affected because kernel is built with compatibility flag there, but patch 
may help there too.

Comment 1 Vilius Šumskas 2007-07-11 19:50:31 UTC
Created attachment 158995 [details]
Patch for oidentd under kernel 2.6.21 and up

Comment 2 Matthias Saou 2007-08-06 11:31:52 UTC
Thanks! I've applied your patch to devel. Could you please test the resulting
package and tell me if it now works for you? I'll then backport the changes to F7.

http://koji.fedoraproject.org/koji/buildinfo?buildID=12934

Comment 3 Vilius Šumskas 2007-08-12 07:20:51 UTC
Yes it works. Thank you!

Comment 4 Matthias Saou 2007-08-12 14:27:47 UTC
Great, I'll rebuild an update for Fedora 7 too.

Comment 5 Fedora Update System 2007-08-13 17:02:34 UTC
oidentd-2.0.8-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2007-08-20 16:02:26 UTC
oidentd-2.0.8-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.