Bug 24788 - Two occurances in libc.so.6
Two occurances in libc.so.6
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-23 19:32 EST by Chris Horler
Modified: 2016-11-24 10:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-23 19:32:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Horler 2001-01-23 19:32:10 EST
I have all the updates installed that are posted on the errata for RH7.

I have installed XFree 4.0.2 and qt-2.2.3

The updates were installed after XFree and qt.  The first time I ran
xf86cfg (new config tool) I got no problems, then the second time it
sigsegv.  I wasn't to concerned at first because it's not very developed. 
Then when konqueror was running it crashed when going to view a web page. 
I've prepared backtraces of both situations, pasted below; the first is
xf86cfg the second konqueror.

(gdb) run
Starting program: /usr/X11R6/bin/xf86cfg
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
Module ABI versions:
        XFree86 ANSI C Emulation: 0.1
        XFree86 Video Driver: 0.3
        XFree86 XInput driver : 0.1
        XFree86 Server Extension : 0.1
        XFree86 Font Renderer : 0.2
Loader running on linux
(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x402e5d3b in strlen () from /lib/libc.so.6
(gdb) bt
#0  0x402e5d3b in strlen () from /lib/libc.so.6
#1  0x806cbfe in LoaderInitializeOptions ()
#2  0x8065cb9 in main ()
#3  0x4027df31 in __libc_start_main (main=0x80652e0 <main>, argc=1,
    ubp_av=0xbffffa3c, init=0x80527d4 <_init>, fini=0x80a3e9c <_fini>,
    rtld_fini=0x4000e274 <_dl_fini>, stack_end=0xbffffa34)
    at ../sysdeps/generic/libc-start.c:129


-----------------------------------------------------------------

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...0x40c60e69 in __wait4 () from /lib/libc.so.6
#0  0x40c60e69 in __wait4 () from /lib/libc.so.6
#1  0x40ccce4c in __DTOR_END__ () from /lib/libc.so.6
#2  0x404ba038 in KCrash::defaultCrashHandler () from
/usr/lib/libkdecore.so.3

#3  <signal handler called>
#4  0x40f95917 in DOM::NamedAttrMapImpl::detachFromElement ()
   from /usr/lib/libkhtml.so.3

#5  0x40f93137 in DOM::ElementImpl::~ElementImpl () from
/usr/lib/libkhtml.so.3

#6  0x40fb3022 in DOM::HTMLElementImpl::~HTMLElementImpl ()
   from /usr/lib/libkhtml.so.3
#7  0x40fbf9c7 in DOM::HTMLAreaElementImpl::~HTMLAreaElementImpl ()
   from /usr/lib/libkhtml.so.3
#8  0x40fb467b in DOM::HTMLAnchorElementImpl::~HTMLAnchorElementImpl ()
   from /usr/lib/libkhtml.so.3
#9  0x40f8fdce in DOM::NodeBaseImpl::~NodeBaseImpl ()
   from /usr/lib/libkhtml.so.3

#10 0x40f93179 in DOM::ElementImpl::~ElementImpl () from
/usr/lib/libkhtml.so.3

#11 0x40fb3022 in DOM::HTMLElementImpl::~HTMLElementImpl ()
   from /usr/lib/libkhtml.so.3
#12 0x40fb45ab in DOM::HTMLGenericElementImpl::~HTMLGenericElementImpl ()
   from /usr/lib/libkhtml.so.3
#13 0x40f8fdce in DOM::NodeBaseImpl::~NodeBaseImpl ()
   from /usr/lib/libkhtml.so.3

#14 0x40f93179 in DOM::ElementImpl::~ElementImpl () from
/usr/lib/libkhtml.so.3

#15 0x40fb3022 in DOM::HTMLElementImpl::~HTMLElementImpl ()
   from /usr/lib/libkhtml.so.3
#16 0x4106095b in DOM::HTMLDListElementImpl::~HTMLDListElementImpl ()
   from /usr/lib/libkhtml.so.3
#17 0x40f8fdce in DOM::NodeBaseImpl::~NodeBaseImpl ()
   from /usr/lib/libkhtml.so.3

#18 0x40f93179 in DOM::ElementImpl::~ElementImpl () from
/usr/lib/libkhtml.so.3

#19 0x40fb3022 in DOM::HTMLElementImpl::~HTMLElementImpl ()
   from /usr/lib/libkhtml.so.3
#20 0x40fb86ff in DOM::HTMLBodyElementImpl::~HTMLBodyElementImpl ()
   from /usr/lib/libkhtml.so.3
#21 0x40f8fdce in DOM::NodeBaseImpl::~NodeBaseImpl ()
   from /usr/lib/libkhtml.so.3

#22 0x40f93179 in DOM::ElementImpl::~ElementImpl () from
/usr/lib/libkhtml.so.3

#23 0x40fb3022 in DOM::HTMLElementImpl::~HTMLElementImpl ()
   from /usr/lib/libkhtml.so.3
#24 0x40fbbaeb in DOM::HTMLHtmlElementImpl::~HTMLHtmlElementImpl ()
   from /usr/lib/libkhtml.so.3
#25 0x40f8fdce in DOM::NodeBaseImpl::~NodeBaseImpl ()
   from /usr/lib/libkhtml.so.3
#26 0x40f8bb3d in DOM::DocumentImpl::~DocumentImpl ()
   from /usr/lib/libkhtml.so.3
#27 0x40fb5f92 in DOM::HTMLDocumentImpl::~HTMLDocumentImpl ()
   from /usr/lib/libkhtml.so.3
#28 0x40f4190b in KHTMLPart::clear () from /usr/lib/libkhtml.so.3
#29 0x40f46ad3 in KHTMLPart::begin () from /usr/lib/libkhtml.so.3
#30 0x40f455da in KHTMLPart::slotData () from /usr/lib/libkhtml.so.3
#31 0x401bba83 in KIO::TransferJob::data () from /usr/lib/libkio.so.3
#32 0x401a1e65 in KIO::TransferJob::slotData () from /usr/lib/libkio.so.3
#33 0x4019ebe4 in KIO::SlaveInterface::data () from /usr/lib/libkio.so.3
#34 0x4019b445 in KIO::SlaveInterface::dispatch () from
/usr/lib/libkio.so.3
#35 0x4019b205 in KIO::SlaveInterface::dispatch () from
/usr/lib/libkio.so.3
#36 0x401c2950 in KIO::Slave::gotInput () from /usr/lib/libkio.so.3
#37 0x406e3f95 in QObject::activate_signal ()
   from /usr/lib/qt-2.2.3/lib/libqt.so.2
#38 0x4073ab76 in QSocketNotifier::activated ()
   from /usr/lib/qt-2.2.3/lib/libqt.so.2
#39 0x40717d17 in QSocketNotifier::event ()
   from /usr/lib/qt-2.2.3/lib/libqt.so.2

#40 0x4068e321 in QApplication::notify () from
/usr/lib/qt-2.2.3/lib/libqt.so.2

#41 0x4046050d in KApplication::notify () from /usr/lib/libkdecore.so.3
#42 0x4065baeb in sn_activate () from /usr/lib/qt-2.2.3/lib/libqt.so.2
#43 0x4065c359 in QApplication::processNextEvent ()
   from /usr/lib/qt-2.2.3/lib/libqt.so.2
#44 0x4069014c in QApplication::enter_loop ()
   from /usr/lib/qt-2.2.3/lib/libqt.so.2
#45 0x4065bb57 in QApplication::exec () from
/usr/lib/qt-2.2.3/lib/libqt.so.2
#46 0x40d30386 in main () from /usr/lib/konqueror.so
#47 0x804a3cc in strcpy () at ../sysdeps/generic/strcpy.c:31
#48 0x804ac6a in strcpy () at ../sysdeps/generic/strcpy.c:31
#49 0x804aff2 in strcpy () at ../sysdeps/generic/strcpy.c:31
#50 0x804c2da in strcpy () at ../sysdeps/generic/strcpy.c:31
#51 0x40bc4f31 in __libc_start_main (main=0x804bef0 <strcpy+8716>, argc=7,
    ubp_av=0xbffffa9c, init=0x804973c <_init>, fini=0x804c668 <_fini>,
    rtld_fini=0x4000e274 <_dl_fini>, stack_end=0xbffffa94)
    at ../sysdeps/generic/libc-start.c:129


Thanks,

Chris.
Comment 1 Jakub Jelinek 2001-01-24 04:43:49 EST
The first case looks like a bug in xf86cfg, the fact that you see it crashing
in strlen just means that xf86cfg called strlen with some bogus or NULL pointer.
The latter again has nothing to do with glibc, if you look carefully into the
backtrace, there was a segfault signal received at #3 and #0-#2 happen in
the crash handler which catches the segfault.
Please submit this as 2 bugreports for the appropriate components and include
full details on how can it be reproduced.

Note You need to log in before you can comment on or make changes to this bug.