Bug 247913 - Black screen on boot up - PCI cards not detected properly
Black screen on boot up - PCI cards not detected properly
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 19:23 EDT by David
Modified: 2008-01-08 17:24 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 17:24:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmeg output as log file (18.54 KB, text/plain)
2007-07-12 03:50 EDT, David
no flags Details
lspci -n > lspci.log (429 bytes, text/plain)
2007-07-18 18:28 EDT, David
no flags Details

  None (edit)
Description David 2007-07-11 19:23:16 EDT
Description of problem:
On power up as X windows should start, screen goes black and stays black.  This
is from kernel 2.6.21-1.3255.fc7 in updates-testing.  However this was reported
in bug 242391

Version-Release number of selected component (if applicable):
kernel 2.6.21-1.3255.fc7

How reproducible:
Completely

Steps to Reproduce:
1.Install kernel kernel 2.6.21-1.3255.fc7 machine no longer has xwindows
2.
3.
  
Actual results:
Use kernel kernel 2.6.21-1.3255.fc7 and PCI cards not detected properly.  Use
kernel 2.6.21-1.3228.fc7 and the machine works perfectly.  However the earlier
F7 kernel 2.6.21-1.3194.fc7 also had this bug.  So we therefore know that kernel
2.6.21-1.3228.fc7 has the fix in it by accident.

Expected results:
PCI cards and machine should be detected properly.  Kernel 2.6.21-1.3255.fc7
should not leave updates-testing as it needs to be fixed.

Additional info:
Comment 1 David 2007-07-12 03:50:01 EDT
Created attachment 159036 [details]
dmeg output as log file

Clearly the PCI bus is mixed up by the kernel and the video card is not being
used.  Previously at least text mode worked, so its completely unusable with
3255 kernel.  I got the dmesg output by remote shell into the machine that is
all I can do, anything local is not possible.
Comment 2 David 2007-07-17 20:34:03 EDT
I just saw in updates-testing new kernel:
kernel-2.6.22.1-20.fc7.i686.rpm

This kernel STILL has the bug, so like previous updates-testing
kernel-2.6.21-1.3255.fc7, this kernel-2.6.22.1-20.fc7.i686.rpm should not leave
updates-testing. 
Comment 3 Jarod Wilson 2007-07-17 21:11:59 EDT
From your dmesg output:

PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report

Does it help?
Comment 4 David 2007-07-18 05:14:11 EDT
Hi Jarod,

No its something getting screwed up in the initialisation and detection of all
the PCI cards.

I get this error in dmesg:

PCI: Probing PCI hardware (bus 00)
PCI quirk: region 0400-047f claimed by ICH4 ACPI/GPIO/TCO
PCI quirk: region 0480-04bf claimed by ICH4 GPIO

The one and ONLY F7 kernel that works is 2.6.21-1.3228.fc7

Any way of finding out why this kernel (2.6.21-1.3228.fc7) is the only one that
is compatible?  On FC6 I never had a problem, but F7 from the start has never
worked I had problems installing it due to the kernel on the installation dvd.
Comment 5 Jarod Wilson 2007-07-18 10:46:21 EDT
diff'ing exploded source trees between 3228 and a closely-versioned non-working
kernel or two, then investigating the differences is probably the easiest way to
figure out what that works and others don't. So are you confirming that you
tried pci=routeirq and it didn't help?
Comment 6 Chuck Ebbert 2007-07-18 12:58:44 EDT
(In reply to comment #4)
> I get this error in dmesg:
> 
> PCI: Probing PCI hardware (bus 00)
> PCI quirk: region 0400-047f claimed by ICH4 ACPI/GPIO/TCO
> PCI quirk: region 0480-04bf claimed by ICH4 GPIO
> 

Is this with a working or a non-working kernel?
Or is it the same message on both?
Comment 7 David 2007-07-18 18:10:07 EDT
Hi Chuck,

I only get this message on a non working kernels, a working kernel produces no
pci quirk error and xwindows and all runs just perfectly.  So in other words
every single F7 kernel released from the start with the only exemption of 3228


Hi Jarod,

I booted 2.6.22.1-20 with a option of pci=routeirq and I still a error something
like:

pci device 0:00:00:00 unknown header error type 30

However I only saw this error once, hence I can't give it to you exactly.  All
subsequent reboots I just get a failed xwindows to start on boot and it runs in
text mode, however a dmesg still reports the PCI quirk error
> PCI: Probing PCI hardware (bus 00)
> PCI quirk: region 0400-047f claimed by ICH4 ACPI/GPIO/TCO
> PCI quirk: region 0480-04bf claimed by ICH4 GPIO
Comment 8 Chuck Ebbert 2007-07-18 18:15:47 EDT
Can we get the output of 'lspci -n' to see the numeric PCI IDs of the devices?
Comment 9 David 2007-07-18 18:28:18 EDT
Created attachment 159565 [details]
lspci -n > lspci.log

Hi Chuck,

Here is a lspci -n > lspci.log but from working kernel 2.6.21-1.3228

Let me know.
Comment 10 Chuck Ebbert 2007-07-19 09:51:41 EDT
(In reply to comment #9)
> 
> Here is a lspci -n > lspci.log but from working kernel 2.6.21-1.3228

What does it look like when X isn't working?
Comment 11 David 2007-07-20 08:29:49 EDT
Hi Chuck,

Go up to comment number 1 and there is a dmesg attachment
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=159036

This is from kernel 3255

Comment 12 Jarod Wilson 2007-07-20 12:29:22 EDT
I believe Chuck was asking for what lspci -n output looked like on a non-working
kernel.
Comment 13 David 2007-07-26 19:45:57 EDT
00:00.0 0600: 8086:1a30 (rev 03)
00:01.0 0604: 8086:1a31 (rev 03)
00:1e.0 0604: 8086:244e (rev 12)
00:1f.0 0601: 8086:2440 (rev 12)
00:1f.1 0101: 8086:244b (rev 12)
00:1f.2 0c03: 8086:2442 (rev 12)
00:1f.3 0c05: 8086:2443 (rev 12)
00:1f.4 0c03: 8086:2444 (rev 12)
02:04.0 0104: 1095:0680 (rev 02)
02:09.0 0401: 1274:5880 (rev 02)
02:0a.0 0200: 10ec:8169 (rev 10)


This is from kernel_2.6.22.1-33.fc7.i686

Comment 14 Chuck Ebbert 2007-07-27 16:02:03 EDT
Somehow the bridge isn't being detected correctly, or the devices behind
it aren't being discovered.

Some things to try (separately):

   pci=nobios
or
   pci=bios
Comment 15 David 2007-07-28 05:59:24 EDT
Hi Chuck,

No joy on either (I get the same result) the machine boots up in text mode only
and then complains xserver won't start.  I then diagnose why no adapters are found.

Comment 16 David 2007-08-01 03:08:00 EDT
Guys any update on this bug or can it get assigned please?

I just tried kernel 2.6.22.1-41.fc7 and its STILL broken.

Even kernel-2.6.21-1.3228.fc7 its a little flaky as sometimes I get a black screen.

Clearly something is amiss in the fc7 kernels.
Comment 17 David 2008-01-08 17:24:43 EST
Well Fedora 8 installs and runs on the machine perfectly so what ever the bug is
has been resolved by Fedora 8

Note You need to log in before you can comment on or make changes to this bug.