Bug 247928 - Elf self-test fails, build completes despite failure
Elf self-test fails, build completes despite failure
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-11 22:10 EDT by Steve Snyder
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 07:43:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2007-07-11 22:10:50 EDT
Description of problem:

Self-test fails on elf test

Version-Release number of selected component (if applicable):

glibc-2.6-4

How reproducible:

Always

Steps to Reproduce:

1. Build package: rpmbuild -bb --target i686 SPEC/glibc.spec
2. When build completes (successfully), examine file BUILD/glibc-20070515T2025/
build-i686-linuxnptl/check.log
3. Note failure of elf test, which ends the test suite
  
Actual results:

Elf test fails, causing end of elf-test.  Build continues, packaging binaries.

Expected results:

1. Self-tests should not fail.
2. Build should not complete if test(s) fails.

Additional info:

Seen on a fully-updated Fedora7 system.
Comment 1 Jakub Jelinek 2007-07-12 07:43:17 EDT
That's caused by the Fedora specific malloc/mtrace.c changes, but it is really
not a bug.

Note You need to log in before you can comment on or make changes to this bug.