Bug 247970 - gconfig can not load config file properly
gconfig can not load config file properly
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-12 09:11 EDT by The Source
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 05:17:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel config file (75.78 KB, application/octet-stream)
2007-09-19 01:02 EDT, The Source
no flags Details

  None (edit)
Description The Source 2007-07-12 09:11:21 EDT
Description of problem:
When I try load config from file (File->Load) utility just duplicates existing
tree. So I have two trees of duplicated settings. None of them are loaded
properly from specified file, they are the same. Example: in default config
wireless cards drivers are disabled. So I tried to load config from /boot
directory from config file that came with binary package of the kernel. But all
I've got is two sets of default (no wifi) options.

Version-Release number of selected component (if applicable):
2.6.21.5

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Christopher Brown 2007-09-18 11:08:57 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 2 The Source 2007-09-18 13:05:28 EDT
Yes, the problem still persists. 2.6.22.5 (6-rc1)
Comment 3 Christopher Brown 2007-09-18 16:53:39 EDT
Please specify the following so that this bug can be reviewed further:

-The file you are trying to load (possibly attaching it to this bugzilla as well)
-The utility you are using to load it and its upstream URL (do you mean gconfig?)
-The wireless card you indicate does not work
-as an attachment, an output from lspci

This does not look like a kernel bug.

Cheers
Chris
Comment 4 The Source 2007-09-19 01:02:40 EDT
Created attachment 199191 [details]
Kernel config file

Here's typical config file. To launch utility simply unpack kernel src.rpm,
apply some patches if you want, type 'make gconfig'.

My wifi adapter works if I manually enable it's driver in config. Anyway this
is not the problem we discuss here. The problem is in gconfig utility.
Comment 5 Christopher Brown 2007-09-19 05:17:23 EDT
I cannot reproduce here. If you need help compiling your own kernel please
follow these guidelines:

http://fedoraproject.org/wiki/Docs/CustomKernel

You may find make xconfig a better option for you. You should not need to
re-compile a kernel to enable wireless drivers.
Comment 6 Chuck Ebbert 2007-09-19 15:47:27 EDT
(In reply to comment #4)
> Created an attachment (id=199191) [edit]
> Kernel config file
> 
> Here's typical config file. To launch utility simply unpack kernel src.rpm,
> apply some patches if you want, type 'make gconfig'.
> 
> My wifi adapter works if I manually enable it's driver in config. Anyway this
> is not the problem we discuss here. The problem is in gconfig utility.

Just copy the file you want to use over the default .config file.

Note You need to log in before you can comment on or make changes to this bug.